WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Image URL Attachment issue (11 posts)

  1. mexpress
    Member
    Posted 1 year ago #

    Dear all,

    I have this image URL issue.
    When i open a post and click on the image, instead of getting the image i'm taken to another page. Please refer this issue here

    I need to have the image to show directly like this at one click on the picture... http://www.mizonews.net/wp-content/uploads/lalthanhawla.jpg instead of having to click the image several times.

    Please help.

    Thanks
    Lily

  2. wgarcia
    Member
    Posted 1 year ago #

    Hi,

    Do you insert the image in the post? or is it a "featured image"?

  3. mexpress
    Member
    Posted 1 year ago #

    I use both insert and featured.

  4. mexpress
    Member
    Posted 1 year ago #

    That's not all. Even Google has stopped indexing these images for Google News as well.

  5. wgarcia
    Member
    Posted 1 year ago #

    Try this:

    When you upload the image and before you click the "Insert into post" button click on the "File URL" button, which is located below the "Link URL" text field. This way, the image on you post will be linked directly to the image file.

    I hope it works

  6. mexpress
    Member
    Posted 1 year ago #

    wgarcia, thanks. i'll try now.

  7. mexpress
    Member
    Posted 1 year ago #

    @wgarcia, Thanks a lot. It worked. :)

    By the way, can you help me with the Google images & Google News Image as well. Earlier it worked fine even with My robot text that was

    User-agent: *
    Disallow: /wp-admin/
    Disallow: /wp-includes/

    ------------
    A few minutes ago..i changed to
    User-agent: *
    Disallow: /wp-admin/
    Allow: /wp-includes/

    Can you please suggest....

    Thanks

  8. wgarcia
    Member
    Posted 1 year ago #

    I'm glad it worked :)

    About the other topic, please check this http://codex.wordpress.org/Search_Engine_Optimization_for_WordPress#Robots.txt_Optimization
    It has some useful links that will help you with that.

  9. mexpress
    Member
    Posted 1 year ago #

    Thanks.

    Will using this be the best?
    Sitemap: http://www.example.com/sitemap.xml

    # Google Image
    User-agent: Googlebot-Image
    Disallow:
    Allow: /*

    # Google AdSense
    User-agent: Mediapartners-Google*
    Disallow:

    # digg mirror
    User-agent: duggmirror
    Disallow: /

    # global
    User-agent: *
    Disallow: /cgi-bin/
    Disallow: /wp-admin/
    Disallow: /wp-includes/
    Disallow: /wp-content/plugins/
    Disallow: /wp-content/cache/
    Disallow: /wp-content/themes/
    Disallow: /trackback/
    Disallow: /feed/
    Disallow: /comments/
    Disallow: /category/*/*
    Disallow: */trackback/
    Disallow: */feed/
    Disallow: */comments/
    Disallow: /*?
    Allow: /wp-content/uploads/

    I'm asking this bcoz i'm a newbie in robot settings...

  10. wgarcia
    Member
    Posted 1 year ago #

    Well, I'm a newbie at this too, so I won't be helpful this time : )

  11. mexpress
    Member
    Posted 1 year ago #

    wgarcia,

    thanks a lot. got the images crawled again.

Topic Closed

This topic has been closed to new replies.

About this Topic