WordPress.org

Ready to get started?Download WordPress

Forums

Image uploads not showing only text. (8 posts)

  1. totalgaz
    Member
    Posted 4 years ago #

    I have been trying to add images to my posts in wordpress 2.8 but after installing it through the flash loader the image is in my wp-content but has a broken page sign in the dashboard post section and when I try preview live or publish. I have tried using the link url directed to the image in the uploaded file still no luck. I used 2.7 before no problems. Any suggestions I have left one of the broken image problems on one of my posts chirocentre.co.uk./tempur-pedic-pillows should see on the right hand side "Tempur Travel Pillow in a grey text box.

  2. whooami
    Member
    Posted 4 years ago #

    so there is supposed to be an image here..

    http://chirocentre.co.uk/wp-content/uploads/Tempur_Travel_Pillow.jpg

    does that image exist on the server at that location?

    does the media gallery show the newly uploaded images?

  3. totalgaz
    Member
    Posted 4 years ago #

    Going through ftp on the server I can see all my other images from 2.7.1 in the folder "uploads" under wp-content and the new images i have been trying to insert into posts are stored in the wp-content level not the sub folder "uploads". When using the dashboard media gallery I can see the names of the newest images in wp-content as mentioned earlier but not the images.

  4. totalgaz
    Member
    Posted 4 years ago #

    I forgot to add http://chirocentre.co.uk/wp-content/uploads/Tempur_Travel_Pillow.jpg is saved in lower case on the server does this make a difference i.e /Tempur_Travel_Pillow.jpg is /tempur_travel_pillow.jpg on the server.

  5. whooami
    Member
    Posted 4 years ago #

    youre not answering the questions.

    So now I have another.

    http://chirocentre.co.uk/wp-content/uploads/tempur_travel_pillow.jpg

    is not the same as this:

    http://chirocentre.co.uk/wp-content/uploads/Tempur_Travel_Pillow.jpg

    theyre both throwing 404s though. Do either exist on the server?

    if you just want to write, thats fine -- let me know though before I spend more time here.

  6. totalgaz
    Member
    Posted 4 years ago #

    Yes they do both exist as I had mentioned so far on my server which I had logged onto through the ftp software that is where I'm looking at them. So I don't know why they are creating 404's. So why would the image names show in the media gallery but not no actual image?

  7. whooami
    Member
    Posted 4 years ago #

    do you have any .htaccess files on the server? what is inside them?

  8. totalgaz
    Member
    Posted 4 years ago #

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I have found that I can upload an image file through the media button but the image will not show until I use my ftp to transfer the image which will now be saved on the server under the folder "wp-content" and move the image file into the sub-folder "uploads".

Topic Closed

This topic has been closed to new replies.

About this Topic