WordPress.org

Ready to get started?Download WordPress

Forums

Image Uploads Directory not Updating (11 posts)

  1. spiralmedia
    Member
    Posted 4 years ago #

    I am uploading images via the media page, add new media. The images are getting uploaded to a directory that is wp-content/uploads/2010/02/image.jpg but the /02 directory is not being created and so the images are coming up as [x], aka not there.

    The url path is giving that new directory, but it is not being created. I recently switched the site to a new domain name for my client.

    I don't normally use the media gallery, but she does and so am I missing a setting or something as to why this will not create the new directories for each month as needed and show the images.

    url: http://madcapz.net

    Thanks for any help!

  2. Samuel B
    moderator
    Posted 4 years ago #

    ftp to site or use host's file manager to change permissions on /wp-content to 777

    do an upload
    should work
    chmod /wp-content back to 755
    should work correctly from now on

  3. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you checked the settings in Admin/Settings/Miscellaneous? Also try changing the permissions on the wp-content directory to 766. If you still have problems, try 767 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

  4. spiralmedia
    Member
    Posted 4 years ago #

    I tried that as you suggested, but it did not resolve the issue. It is still not creating the /02 directory nor showing the image. Any other suggestions would be appreciated. Thanks.

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you checked to see if you've exhausted your disk space quota in your hosting package recently?

  6. spiralmedia
    Member
    Posted 4 years ago #

    Definitely have not as this is a new site that just got set up and there is very little disk space used up. Is there any other reason the system would not create these new directories on the fly, any setting I'm missing or something? Thanks.

  7. esmi
    Forum Moderator
    Posted 4 years ago #

    The most common issue is folder permissions. What kind of hosting package are you using - Linux or Windows?

  8. spiralmedia
    Member
    Posted 4 years ago #

    Linux, shared hosting. But I have maybe 30 blogs through this host on the same hosting packages and using WordPress and this is the first time this has ever happened. Could it have something to do with changing the primary domain name and the images trying to upload to the development domain that was in place prior to the switch? Thanks.

  9. esmi
    Forum Moderator
    Posted 4 years ago #

    It's possible. How did you make the domain name change?

  10. spiralmedia
    Member
    Posted 4 years ago #

    The host changed the primary from madcapzdev.net to madcapz.net and then I just changed the settings in the admin to reflect the new address. Then they parked madcapzdev.net and that was pretty much it. I put a support request into them to see if they know of why it might be not working either. They probably won't respond until later today or tomorrow. Hopefully, it can be figured out.

  11. esmi
    Forum Moderator
    Posted 4 years ago #

    Aha! The urls won't have changed throughout the database. Although you've already changed things, have a read of:
    http://codex.wordpress.org/Moving_WordPress
    and
    http://codex.wordpress.org/Changing_The_Site_URL

Topic Closed

This topic has been closed to new replies.

About this Topic