WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Image Uploading with WP2.0 (16 posts)

  1. chelle-mom
    Member
    Posted 8 years ago #

    I am having troubles with the Image Uploading and WP2.0
    When I attempt to upload a pic I get this:

    Unable to create directory /home/httpd/vhosts/soodz.com/httpdocs/blog/wp-content/uploads/2005/12. Is /home/httpd/vhosts/soodz.com/httpdocs/blog/wp-content/uploads/2005 writable?
    Back to Image Uploading

    I have no idea what the 2005 part is but my uploads folder on my server is 777 writable and all that jazz.

    Help!?"!?! I love that feature of 2.0

    thanks everyone!
    chelle

  2. chelle-mom
    Member
    Posted 8 years ago #

    Did I post this in the wrong area? Or are people uber busy?

    I am still having this issue and since I am inexperienced I do nto know what else to try.
    thanks
    chelle

  3. vkaryl
    Member
    Posted 8 years ago #

    I think it's probably the time of year.... I can't help you with this issue: I seldom use graphics, and if I did I wouldn't use the upload thing anyway....

  4. chelle-mom
    Member
    Posted 8 years ago #

    Totally a bad time of year...thanks for the reply. I guess I will post my images the old fashioon way for now :)
    chelle

  5. lisavollrath
    Member
    Posted 8 years ago #

    I'm having the same problem. My permissions on the directory are wide open, but it's still not accepting uploads.

  6. Tutor
    Member
    Posted 8 years ago #

    I had the same problem I believe. to over come it you ensure the "uploads" dir is writable... then wp will create the "205" dir and it will need to be made writeable... finally (you guessed it) a "12" dir will be made and it needs to be writeable... or do it all yourself creating the dir's and making them writeable yourself before the errors... now the key thing to remember is tomorrow will be 2006... and guess what?
    Tutor

  7. chelle-mom
    Member
    Posted 8 years ago #

    Thanks Tutor!
    I will give that a try and post back if it works (or not)
    Really apprecaite the reply!
    chelle

  8. stellarlogic
    Member
    Posted 8 years ago #

    I am having the same problem I think - but only in pages. Not in the main blog body. Cannot for the life of me figure it out.

  9. chelle-mom
    Member
    Posted 8 years ago #

    Tutor YOU ROCK!!! It's fixed I can use the most valuable part of WP2.0!!! (Well most valuable to me...I post a pic a day!!!!)

    I am so excited!!

    THANK YOU!
    Thank you
    Thank you!
    chelle

  10. mniepert
    Member
    Posted 8 years ago #

    For those who don't want to change the permissions monthly here is a work-around suggestion: Open the file "functions-post.php" in the folder "wp-includes" go to line 847 in function wp_upload_dir() and change the following code fragment

    // Give the new dirs the same perms as wp-content.
    $stat = stat(ABSPATH . 'wp-content');

    to

    // Give the new dirs the same perms as wp-content/uploads.
    $stat = stat(ABSPATH . 'wp-content/uploads');

    Now the new folders get the same permissions as the upload folder which you chmod to 750 beforehand. You will never have to chmod the folders and files anymore and it is more secure than changing the permissions of the wp-content folder itself. However, consider that all your "uploads" subfolders and files are readable by "group".

    Mathias

  11. zota
    Member
    Posted 8 years ago #

    I don't want to use this new upload system, but I no longer have any upload options in Miscellaneous Options -- have the upload options been removed from WordPress 2?

    Core hacks? Hardcoded file directories? What happened???

  12. delano
    Member
    Posted 8 years ago #

    Mathias,

    I tried what you suggested but it didn't work. I am also unable to remove the uploads folder nor change permissions on it. Any suggestions?

  13. delano
    Member
    Posted 8 years ago #

    ok - i was able to delete the folder using terminal but this is the error I'm receiving:

    Warning: move_uploaded_file(): SAFE MODE Restriction in effect. The script whose uid is 810 is not allowed to access /home/mirele58/public_html/wp-content/uploads/2006/01 owned by uid 99 in /home/mirele58/public_html/wp-admin/admin-functions.php on line 1757
    The uploaded file could not be moved to .

    Any Ideas?

  14. kickass
    Member
    Posted 8 years ago #

    The iimage plugin perhaps? Works like a charm.

  15. mniepert
    Member
    Posted 8 years ago #

    delano, your php probably runs as Apache module. Unfortunately, in this case, you have to set permissions of the "uploads" folder to 777 instead of 750.

  16. jboulton06
    Member
    Posted 7 years ago #

    I'm having upload problems. I've changed the right on:
    wp-content, uploads to 777. When I upload a file is created inside the uploads folder. Inside this folder is the year 2006, then the month 11 (name of folder) was created, however I get the message: The uploaded file could not be moved to .

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.