WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Image uploader not opening in iframe (8 posts)

  1. Simon Blackbourn
    Member
    Posted 5 years ago #

    Hi

    I am having exactly the same problem as here: http://wordpress.org/support/topic/191038.

    I have several sites running WordPress, versions 2.6.5 & 2.7, on my own server, all work perfectly. But I have just upgraded a site hosted on a different server to 2.7, and now the image uploader doesn't open in the iframe, instead it loads in the main page, so I lose my post, and the 'insert into post' does not work. It worked fine when it was running 2.6.5.

    I have disabled all plugins, cleared my cache (several times!), but nothing works.

    Any ideas what might be causing this?

  2. danatstadiumvolleyball
    Member
    Posted 5 years ago #

    Exact same issue as http://wordpress.org/support/topic/224344?replies=3#post-922716

    What theme are you using?

  3. Simon Blackbourn
    Member
    Posted 5 years ago #

    aha! thanks very for the pointer - i was using my own theme, so i've just tried activating the default theme and it now works fine.

    time to go through my code with a fine toothcomb and find what's causing the trouble...!

  4. Simon Blackbourn
    Member
    Posted 5 years ago #

    i was loading my javascripts using the wp_print_scripts action, but it turns out that this is also called when you're in the admin screens.

    i've now added a if(!is_admin()) check before loading my javascripts and all works fine.

  5. brakeshot
    Member
    Posted 5 years ago #

    same problem after i upgraded to wordpress 2.7.
    Tried with the default template but doesnot solve the problem

  6. doorbells29
    Member
    Posted 5 years ago #

    I'm having this problem too

  7. yasinansari
    Member
    Posted 5 years ago #

    I have been battling with the same issue for a while to the point where I almost gave up on the theme i wanted to use. The last thought I had was to try installing a different editor hoping that may trigger the iframe. And woila it worked :)

    Now that I have it working its pretty simple. Download the following plugin, activate and now not only does the uploader work but you have a far more comprehensive menu bar. Link below ...

    http://wordpress.org/extend/plugins/fckeditor-for-wordpress-plugin/

  8. mcshaw
    Member
    Posted 4 years ago #

    I struggled with this one for my Thesis theme... needed to embed an iframe on a page. Finally got it to work... and was so thrilled, I forgot to check it out on IE... I'm using Chrome. Well, just found out that it doesn't work in IE. In IE, I get the 'webpage cannot be found' error message inside my frame. Also doesn't work in Firefox.

    Any ideas? Please help!!! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic