WordPress.org

Ready to get started?Download WordPress

Forums

Image Uploader Button does nothing (11 posts)

  1. eternaldream
    Member
    Posted 4 years ago #

    I read the sticky topic, and tried some of the things mentioned, but I didn't figure it out. So when I try to create a post, there are those small buttons above for images, videos, music, etc. I'm under the impression that when I click on one, something should pop up, right? But when I click on it, nothing happens.

    I read a few other topics, but I still couldn't figure it out. I tried updating to Flash 10, but that didn't work. I tried restarting Firefox a few times, but that didn't work. It never worked since started anyway. I also made sure the WYSIWYG button is unchecked in the user page. I read something on the codex that said I should change permissions of one of the folders. But the way it was written, it seemed really complex. Plus they said if you installed WordPress yourself (which I did), you shouldn't have to do that.

    So anybody have any ideas I could try to get it to work?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Is your web browser configured to block all popups?

  3. eternaldream
    Member
    Posted 4 years ago #

    Yes, but usually a little box comes up that says a popup has been blocked. And nothing like that happens when I click the button. I don't even see the status bar do anything.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  5. eternaldream
    Member
    Posted 4 years ago #

    Yes, I tried all of those, but nothing works. Right now I don't even have any plugins at all.

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    Do you have JavaScript enabled in your browser?

  7. eternaldream
    Member
    Posted 4 years ago #

    Yes, it is enabled, and still nothing.

  8. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Upgrade your wordpress to latest version and assign 766 recursive permissions to wp-content directory which should resolve the issue.

    Thanks,

    Shane G.

  9. eternaldream
    Member
    Posted 4 years ago #

    I looked into that, but it still doesn't work. I changed my permissions to I think 766. That means for owner I can read, write, and execute, and for group and others you can only read and write. Is that correct? If that's the case, it screws up my entire site when I do that. The theme disappears.

    I tried messing around with other settings, but nothing works. And I have the recent version of WordPress too. Is there any way I can link directly to images that I upload? Like if I created a "Post Images" folder inside my theme's folder, then I would link to them directly? That might be easier to do, but how do I do it? What would be the directory name?

  10. esmi
    Forum Moderator
    Posted 4 years ago #

    f you're going to upload images to your site and link to them manually, I'd suggest setting up a folder (eg called post-imgs) off your root domain folder. Then you can use urls such as http://domain.com/post-imgs/image1.jpg

  11. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    So when I try to create a post, there are those small buttons above for images, videos, music, etc. I'm under the impression that when I click on one, something should pop up, right? But when I click on it, nothing happens.

    When you mouse over any of the buttons, does an address show up in your browser? You should see http://www.yourwebsite/wp-admin/media_upload.php. If you do not see the this, upload the wp-admin folder again. You are missing some files.

Topic Closed

This topic has been closed to new replies.

About this Topic