WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] image upload server path issue (7 posts)

  1. Lil Chris
    Member
    Posted 5 years ago #

    Hey,
    This is probably a silly problem but... I recently moved my wordpress site from one server in mediatemple to another server in mediatemple. Everything seems to be working properly except when I try to upload an image to a page/post. This is the error i'm getting:

    Warning: is_dir() [function.is-dir]: Stat failed for /home/2511/domains/brucelessey.com/html/wp-content/uploads/2008 (errno=13 - Permission denied) in /nfs/c01/h08/mnt/2976/domains/brucelessey.com/html/wp-includes/functions.php on line 1746

    it seems to be trying to create a directory on the old server #, from the new server. How and where do I look to try and fix this pathing problem...?

    I can create new pages/posts with no problems, just can't upload any images/media files. Any thoughts would be greatly appreciated...

    Thanks,
    Lil Chris

  2. Lil Chris
    Member
    Posted 5 years ago #

    Anybody have any thought on what I might try...?

  3. Saurus
    Member
    Posted 5 years ago #

    YES - read the faq in the Codex on moving your URL.

  4. Lil Chris
    Member
    Posted 5 years ago #

    I've searched the files as best I could, there doesn't seem to be anything that specifically addresses my issue.

    Since the site has already been relocated and works (except for the upload/insert image), is there a specific file that handles the image upload path?

  5. Lil Chris
    Member
    Posted 5 years ago #

    Bump

  6. Lil Chris
    Member
    Posted 5 years ago #

    Solution found in another thread.

    1. Log into WordPress.
    2. Go to your Settings->Miscellaneous config screen.
    3. Examine the directory parameter for uploads.
    4. Changed server number in path. (this didn't change when the site was moved, MT uses server numbers)

    Simple and silly as I thought, hope this helps others...

  7. goinhome50
    Member
    Posted 4 years ago #

    There is another solution as well (although not as easy as Lil Chris' advice). If you examine your db files and see this string...

    /nfs/c01/h03/

    ...and you're familiar with working with phpMyAdmin, replace that string in any table that contains that string with:

    /home/

    If you follow Lil Chris' advice, you might see that string in your "Store uploads in this folder" note at the top of the page...simply change the first string to home if you see that code in that input box, and it should work.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.