WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Image Upload Problems on Subdomain (32 posts)

  1. JenFunk
    Member
    Posted 3 years ago #

    I am having trouble uploading images to my subdomain since upgrading to 3.0. The subdomain was added just prior to the upgrade, then after upgrade I removed it completely and started from scratch - long, irrelevant story.

    Image uploads show as a red x in "Media" and when I follow the URL to the image, I receive a 404 error.

    My .htaccess is as follows:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    Upload path: /wp-content/blogs.dir/4/files/
    Upload URL path: http://buzz.modernmamaz.com/files
    Fileupload URL: http://buzz.modernmamaz.com/files

    Example image URL: http://buzz.modernmamaz.com/files/2010/12/ModernMamazBannerBuzz1.jpg

    Any help would be VERY appreciated!

  2. JenFunk
    Member
    Posted 3 years ago #

    Correction: They are NOT uploading correctly to my main site either.

  3. michel83
    Member
    Posted 3 years ago #

    Hello, I am francais and speak not about English, I use Reverso,

    I have exactly the meme probléme,
    No concern(marigold) on the pemier site and everything sous domain,
    Are identical has jenFunk

    Just for information, I use WP 3.0.1 converted in Mu
    I have 95 under domain and the first one works him(her) perfectly,
    Thank you for the brought assistant

  4. Image URLS are rewritten like that on purpose - can you give the the exact location on the server of the image that's not showing up? There will be a /wp-content/blogs.dir/ part in the string.

  5. michel83
    Member
    Posted 3 years ago #

    Hello,
    I understands(includes) that it is necessary to give the place
    But in that she(it) files,

    Saddened for my English,
    The translation is not magnificent lol

  6. michel83
    Member
    Posted 3 years ago #

    Hello Andrea

    I think that I everything not understood has the question,
    Possible of etre the simplest possible for the translation francais ^^ is you it
    Thank you

  7. @michel si vous écrivez d'autres en français, je peux comprendre certaines d'entre elles

    :)

  8. michel83
    Member
    Posted 3 years ago #

    Merci de votre aide Andréa

    Donc dans Média du site principale
    pas de souci l'image s'affiche et le liens de l'image est du style:
    http://monsite/france/wp-content/uploads/2010/12/pics.jpg

    j'ai 95 sous domaine, (95 departement francais)

    si je vais sur un autre departement,
    dans media
    l'image ne s'affiche pas,
    elle n'est pas télécharger

    url de l'image est:
    http://(nom du sous domaine.mon site/france/files/2010/12/pics.jpg

    et donc pas d'image

    Merci de ton aide
    sur le forum francais, on as pas trouver!!

  9. michel83
    Member
    Posted 3 years ago #

    I have just seen that the image is good to download in the file in question,
    But in "media" the address to indicate is not good

    - here is the address of the image in my file:

    http://monsite.fr/france/wp-content/blogs.dir/2/files/2010/12/1.bmp

    - that to indicate in "media"

    http://83.monsite.fr/france/files/2010/12/1.bmp

    Quelqun know that it is the file or to find the chaine to ask

    I have to look in fonction.php without finding

    Thank you for your help(assistant)

  10. Check permissions on the uploads folder and see if they are actually ON the server somewhere.

    If yes, check and make sure your htaccess file is the same as the one given when you set up your network, under Tools -> Network.

    If that's fine, check the permissions on the .wp-inckludes/ms-files.php file. try setting it to 755 and see if that works.

  11. michel83
    Member
    Posted 3 years ago #

    Is believed in me in it:):):):)

    No, nothing makes for it,

    The config.php is identical has that to ask in the config reseau
    The htacces is identical also

    Ms-spin him(it) is good in 755,

    I put has in the daytime the reseau,
    Empty masks(hiding places)
    To update, nothing makes for it,

    The address of the url always not maid, is missing the "blogs.dir" and the continuation(suite)

    Thank you

  12. michel83
    Member
    Posted 3 years ago #

    my ".htacces"

    #

    uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www. [NC]
    RewriteCond %{HTTP_HOST} !^monsite.fr$ [NC]
    RewriteCond %{HTTP_HOST} !^monsite.fr$ [NC]
    RewriteCond %{HTTP_HOST} ^([^.]*). [NC]
    RewriteCond %{DOCUMENT_ROOT}/%1 !-d
    RewriteRule ^(.*) http://monsite.fr/ [L,R=301]

  13. The address of the url always not maid, is missing the "blogs.dir" and the continuation(suite)

    That is what is supposed to happen - the htaacess file rewrites the wp-content/blogs.dir/ID#/files/whatever to the other address.

    Can you access the image at wp-content/blogs.dir/ID#/files/ ?

  14. michel83
    Member
    Posted 3 years ago #

    Yes images was to download in the file

    Http: // monsite.fr/france/wp-content/blogs.dir/files/2010 in ....... image.jpg

  15. michel83
    Member
    Posted 3 years ago #

    I can not the inserer in an article or a page or the other one

    Because his(her,its) url is

    Http: // (under domain) .monsite.fr/france/files/2010/12/2/imag es.jpg

  16. I think you need to move some of that up ABOVE WordPress...

    This should be ABOVE the WP calls (though I'm not sure what it's supposed to do):

    RewriteCond %{HTTP_HOST} !^www. [NC]
    RewriteCond %{HTTP_HOST} !^monsite.fr$ [NC]
    RewriteCond %{HTTP_HOST} !^monsite.fr$ [NC]
    RewriteCond %{HTTP_HOST} ^([^.]*). [NC]
    RewriteCond %{DOCUMENT_ROOT}/%1 !-d
    RewriteRule ^(.*) http://monsite.fr/ [L,R=301]

    And your WordPress section should be this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress
  17. michel83
    Member
    Posted 3 years ago #

    I following test and inform you thank you

  18. michel83
    Member
    Posted 3 years ago #

    No it makes nothing, identical toujour,

    On the site head teacher(main clause) I cherge an image in "media"
    The url is:

    http://monsite.fr/france/wp-content/uploads/2010/12/0511101.jpg

    In a sub-domain, the address is:

    http://83.monsite.fr/france/files/2010/12/0511101.jpg

    Voila really,
    Thank you for your help(assistant)

  19. michel83
    Member
    Posted 3 years ago #

    For information,
    I have just deleted(eliminated) the ".htacces" of the waiter(server)

    And his(her,its) exchange nothing, on the site head teacher(main clause), I load(charge) the images no concerns(marigolds)

    On sous domain always similar address éronné!!!!!!!!!

  20. Je parle français comme une vache espagnole.

    I'm able to follow along, though.

    Please make a NEW .htaccess with this only:

    S'il vous plaît .Htaccess avec ce que:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    God, I've only been taking French since the summer!

  21. michel83
    Member
    Posted 3 years ago #

    immédiatly lol very good french lol

  22. michel83
    Member
    Posted 3 years ago #

    No, really saddened, it makes it nothing
    I naturally deleted(eliminated) the mask before trying

    I pete a cable lol

  23. Je parle français comme une vache espagnole.

    lol!

    God, I've only been taking French since the summer!

    And I fine job you're doing! Tip: google translate to double-check. ;)

  24. michel83
    Member
    Posted 3 years ago #

    For it is "Reverso" lol

  25. michel83
    Member
    Posted 3 years ago #

    Who knows the file which appeals?

    It is really crazy, that the site head teacher(main clause) works and that sub-domain not, knowing that he(it) uses both the meme,
    The htacces and the config.php

    I become crazy, for three days above lol

    Some more of help(assistant) please

  26. Without actually going into your server and trying things, there's not much else we can do.

    change /wp-includes/ms-files.php to 777.

    make sure Apache has
    AllowOverride FileInfo Options
    so it will actually *read* the htaccess file.

    If those do not work, we are stumped.

  27. michel83
    Member
    Posted 3 years ago #

    I think not that it comes from the waiter(server), otherwise, head teacher(main clause) would not work either,

    The file.php was deja in 777:)

    Really thank you has you, I am going to uninstall everything to reinstall, derniere solution, I think
    Thank you

  28. I think not that it comes from the waiter(server), otherwise, head teacher(main clause) would not work either,

    the main blog serves uploads form a *different folder*.

  29. michel83
    Member
    Posted 3 years ago #

    Thank you for you has you two, ^^

  30. michel83
    Member
    Posted 3 years ago #

    Hello has all,

    Thus for me, probléme resolved

    I deleted(eliminated) everything and to reinstall, everything works,

    I know, it is not térrible, there esperant that the probléme does not return,

    Thank you has all of your help(assistant),
    Michel

Topic Closed

This topic has been closed to new replies.

About this Topic