WordPress.org

Ready to get started?Download WordPress

Forums

Image upload problems after server move (3 posts)

  1. traypup
    Member
    Posted 2 years ago #

    I recently completed a server move -- 25 sites, most of which are run with WordPress. I just learned that one site has image upload issues resulting in the following error:

    Warning: copy(/home/justmean/public_html/wp-content/uploads/2012/04/eeep_logo.jpg) [function.copy]: failed to open stream: Permission denied in /home/justmean/public_html/wp-admin/includes/file.php on line 348
    2356

    All of my settings are the same as before the move and I double checked permissions. they're all at 755. I even changed them temporarily to 777 and still no go.

    I manually created the folder uploads/2012/04 and before that the error was saying it couldn't create the folder, are the permissions correct. That's when I checked permissions.

    I read every forum post on this topic and tried the following fixes:
    - I have manually reinstalled the entire wordpress app.
    - I have deactivated, tested and reactivated all plugins.
    - My media settings were the same as on the old server, but I changed to the path to say wp-content/uploads
    - I unchecked and tested and rechecked the setting to organize uploads into month and day folders.

    Any suggestions? Thanks!

  2. traypup
    Member
    Posted 2 years ago #

    Problems have been reported about another site that also moved at the same time as the one described above. I'm really at a loss!

  3. traypup
    Member
    Posted 2 years ago #

    (also posted at this discussion)

    It turns out that my php handler was set to one that didn't play nice with this function. Here's what my server guy said:

    We normally recommend switching your PHP handler to either FCGI or suPHP. Both of these are going to work as they will make Apache run as the cPanel user and thus get rid of the permission issues. FCGI will allow you to also run opcode caching software like APC. The only downfall is that FCGI uses more memory then what DSO(your current PHP Handler) uses. suPHP will not allow you to run opcode caching and will not use more memory however, it does use more CPU then any of the other PHP handlers. It has been around longer then FCGI so more people are familiar with it as well. It is going to depend on your preference as to what you want to switch to. Do you want to use more memory or more CPU?

    We switched it to suPHP and it seems to be working ok now.

Topic Closed

This topic has been closed to new replies.

About this Topic