WordPress.org

Ready to get started?Download WordPress

Forums

Image upload problem (15 posts)

  1. Ansay
    Member
    Posted 3 years ago #

    Hello once more

    There is a problem when I upload an image it want show a thumbnail and the link you get to the image want work. It say it can find it, so i thought i look at the FTP and i find the picture but i can not link to so i can not use it. So what to do?

    If i go to the Media Library and then wive the image it will show it like this
    /Jesper C

  2. mymorningstory
    Member
    Posted 3 years ago #

    This actually sounds like a permission problem. Check to see if your permissions are set in that folder to 755 or 777. Make sure the image is set up like that as well.

  3. Ansay
    Member
    Posted 3 years ago #

    done that and they are all 777 and still it want show the image :/

  4. mymorningstory
    Member
    Posted 3 years ago #

    ok, I'm not an expert but heres my opinion;)
    your image is this: http://firefly.wordofmy.com/files/2010/11/02002_theopallake_1440x900.jpg

    But, is that where your image is uploaded at? If you have the image saved in that exact location, w/ correct permissions - then it should appear via that link. I have never had a problem just viewing an image before, unless the link was written incorrectly, or the permissions were bad.

    with that being said, maybe you contact host support?

  5. If the image is there and permissions are okay, what's in your .htaccess file?

  6. Ansay
    Member
    Posted 3 years ago #

    mymorningstory.

    wp-content/blogs.dir/56/files/2010/11/02002_theopallake_1440x900.jpg
    it the patch way on the ftp.
    i will contact them then if you think that is what need to be done

    ipstenu.

    RewriteEngine On
    RewriteBase /
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    That what´s in it

  7. Okay, It looks like you were running WPMU. I would replace that with this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
  8. Ansay
    Member
    Posted 3 years ago #

    Done it and it want to show my image :(. Should i reinstall WordPress? if so how do i export all the blogs that are online now ?

  9. Is this happening on all blogs or just one?

  10. Ansay
    Member
    Posted 3 years ago #

    all of them

  11. Okay, a direct link works so we know the images are there.

    http://firefly.wordofmy.com/wp-content/blogs.dir/56/files/2010/11/02002_theopallake_1440x900.jpg

    However if I try to manually use the ms-files link it doesn't work. First make sure that the ms-files.php file is there in the WP-includes folder. If so ... Can you check if mod-rewrite is fully enabled on your server? Most of the time in this situation, that's the problem.

  12. Ansay
    Member
    Posted 3 years ago #

    ms-files.php is in WP-includes, dose it have to do whit that I had WPMU before WPMS? When i updated it want me too change form blogs.php too wp-files.php in the .htaccess and delete the blogs.php file.

    For mod_rewrite i did this test http://wordofmy.com/rewrite.php

  13. Well .. I'm assuming it all worked on WPMU and broke after you upgraded (which, if so, is something you should always state in the beginning of your posts ;) it's useful!).

    Most likely is you have an incomplete upgrade. Try reuploading all the wordpress 3.0.1 files.

  14. Ansay
    Member
    Posted 3 years ago #

    Okay sorry for that I did not think of it >_< so sorry for that but i will do that :)

  15. And double check the upgrade instructions.
    http://wpmututorials.com/how-to/upgrading-to-3-0/

Topic Closed

This topic has been closed to new replies.

About this Topic