WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Image upload path url, hide primary site name. (10 posts)

  1. LavishDhand
    Member
    Posted 1 year ago #

    Hello!
    I'm working on a MultiSite network where I'm mapping sub-domains to individual sites and I'm using WordPress MU Domain Mapping plugin.

    I notice that all images uploaded by the users on sub-sites have following path format :

    http//SubSite-MainSite-com/wp-content/uploads/sites/2/2013/01/image.jpg

    The same image is accessible at the following url too

    http//Mainsite-com/wp-content/uploads/sites/2/2013/01/image.jpg

    I can actually edit the file path while posting an image but what I want is to set the default path like the second example above, basically I want to hide primary site name. I don't want to show that a site is a part of a MultiSite network. Kindly guide.

  2. You'll always be able to see the images at the following locations:

    http//SubSite-MainSite-com/wp-content/uploads/sites/2/2013/01/image.jpg
    http//MainSite-com/wp-content/uploads/sites/2/2013/01/image.jpg
    http//MappedSite-com/wp-content/uploads/sites/2/2013/01/image.jpg

    Asuming you want the default to be MAPPED site, when you set up domain mapping, you want to UN check 'Remote Login' so everyone always uses mappeddomain.com

    Thus the images will always be the mapped domain.

  3. LavishDhand
    Member
    Posted 1 year ago #

    Oh yes, my mistake. Sorry!

    I meant I wanted them to be http//MappedSite-com/wp-content/uploads/sites/2/2013/01/image.jpg

    Thanks, I will try what you suggest.

    regards

  4. LavishDhand
    Member
    Posted 1 year ago #

    Thank you for the tip this has been of great help. While creating a new page now my users see a less confusing url that is

    http//MappedSite-com/PageName.

    It earlier looked as

    http//MappedSite-MainSite-com/PageName.

    However uploaded images are still showing at

    http//MappedSite-MainSite-com/wp-content/uploads/sites/2/2013/01/image.jpg

    The url reveals if someone hovers the pointer over an image (status bar) and/or if someone right click and 'view image' the full path of the image is shown in the address bar.

  5. What options did you check for Mapped Domains?

    I have ONLY option #2 checked, and my posts are mapped-site.com/page and my images are all at mapped-site.com

    This WILL NOT change old images, though.

  6. LavishDhand
    Member
    Posted 1 year ago #

    I had option#2 and 3 checked, I just unchecked 3 and it is fine. I couldn't understand why UN-checking 'User domain mapping page' worked though.

    Thank you very much :)

  7. LavishDhand
    Member
    Posted 1 year ago #

    Hello again,

    I see now that the resolution has brought me an another problem. I'm super admin to the MS network which earlier let me see any website's dashboard within the network by just logging in once.

    Now, when I want to go to another website dashboard at the network I have to re-login to each of them.

    Is it how it should behave?

    THANKS

  8. I couldn't understand why UN-checking 'User domain mapping page' worked though.

    Yeah, I dunno either, but it works :/

    The login behavior is correct, and has to do with how browsers implement cookie security. Long boring story. tl;dr: You want this, it's for your safety.

  9. ellebillias
    Member
    Posted 1 year ago #

    I'm having the same problem - have deleted images and reuploaded and they still show as mappedsite.mainsite.com/

    have only got option #2 checked and didn't seem to change anything :(

  10. ellebillias
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Topic