WordPress.org

Ready to get started?Download WordPress

Forums

Image Upload only works on small jpg's (5 posts)

  1. guitarman3
    Member
    Posted 9 months ago #

    Since my upgrade to version 3.5.2, I can no longer upload 1.5MB to 2.5MB sized jpg images to my media library. I can upload small images such as 250KB. This is the case with the multi-file uploader and the single file uploader. With the single file uploader I get an error message "Request Entity Too Large." The multi-file loader gives me an "HTTP error." It doesn't get to the 'crunch' stage.

    I contacted my host and he said: "I've check the server config for that server and the maximum upload size is set to 20M for that server. Here's a list of the server settings:

    memory_limit 64M
    upload_max_filesize 20M
    max_execution_time 60
    max_input_time 120 (end quote by my host)

    My theme allows 8MB images to be uploaded. What can I do to resolve this situation? Thanks very much!
    Dennis

  2. Krishna
    Volunteer Moderator
    Posted 9 months ago #

    Large size images may not get uploaded in 60 seconds. Try uploading one by one or ask your hosts to change the sever settings.

    As it is WordPress by default do not have such limitations.

  3. JarretC
    Member
    Posted 9 months ago #

    Are you using any plugins at all? NextGen gallery or something similar that manages images for your site?

    It may be an issue with a plugin that you're using as the default WordPress install should be able to handle those images and you mention it happening only after you upgrade so could be an issue where a plugin that you have doesn't play well with WP 3.5.2

  4. guitarman3
    Member
    Posted 9 months ago #

    JarretC, thanks, I tried your suggestion and deactivated all my plugins and it still does not upload my images. No change.

    Krishna, as I stated in my OP, I tried both uploaders and I have also asked my host to check server settings, whose reply I posted in my OP. It takes about 5 seconds to upload one of my images--not 60 seconds. I see the blue progress bar go across and I get the HTTP error BEFORE the "crunching" indicator is shown. My issue isn't with the speed of the upload, but that I can't upload my images at all (unless I make them tiny).

    Thanks for the replies!

  5. Krishna
    Volunteer Moderator
    Posted 9 months ago #

    My issue isn't with the speed of the upload, but that I can't upload my images at all (unless I make them tiny).

    This is what baffles me. If it's a WordPress problem related to image uploads, you may not be able to even upload the tiny image, IMHO.
    However, I suggest re-uploading freshly downloaded copies of wp-includes and wp-admin to see if that helps.

    You may also try increasing memory:
    Add the "define" line below in your wp-config.php below the opening <?php in that file:

    define('WP_MEMORY_LIMIT', '64M');

    If it doesn't help, change the memory_limit in your php.ini (if you have access to that file) to increase memory to 64M:

    memory_limit = 64M;

Reply

You must log in to post.

About this Topic