WordPress.org

Ready to get started?Download WordPress

Forums

Image upload not working in WordPress 2.8 (95 posts)

  1. onel0ve
    Member
    Posted 5 years ago #

    me face one problem also after update 2.7.1 to 2.8 my site become dam slow maybe 2.8 have bugs

    and image uploaded sucessfully but not showing

  2. atourgates
    Member
    Posted 5 years ago #

    I'm basically having the same problem as everyone else. After upgrading to 2.8, I can't upload images.

    I've fixed permissions, changed upload directories, re-uploaded all my core install files, disabled all my plugins - and still no love. No error codes or anything, just a seemingly completed upload, and no files in my media library or on my FTP.

    One thing I haven't seen mentioned before: I don't have the option to use the Flash uploader. When I click on a media upload icon, I just get the message that says, "You are using the browser uploader" and no option to switch to the flash uploader.

    Crazy. Crazy and lame.

  3. Arvid
    Member
    Posted 5 years ago #

    Same problem here with 2.8 - I get an full 100% image upload bar, then "HTTP Error" when using the flash uploader, and the browser uploader just never finishes. This is on a webhost that has been perfectly fine for all my wordpress installs in the past.

  4. fldtrace
    Member
    Posted 5 years ago #

    I thin I was inspired when I didn't upgrade my websites to this version. Hope next release 2.8.1 will correct the problem.

  5. Arvid
    Member
    Posted 5 years ago #

    When i tried the browser uploader, i once got this:

    Error 500 - Internal server error

    An internal server error has occured!
    Please try again later.

    but usually just nothing.

  6. Arvid
    Member
    Posted 5 years ago #

    its bizarre though that my client seems to be able to upload images fine with her PC (i'm not sure if she is using IE 7 or Firefox, because seems like often she isn't sure herself).

    I'm on Mac and can't get it to work either with Safari 4 or firefox.

    EDIT:

    Ack! This problem is in both a site I upgraded from WP 2.6 to 2.8 and a brand new site using WP 2.8 that has no plugins active, and none beyond the defaults even installed. I tried it with the default theme active - no dice. Disabling Gears did not help. Nor did the .htaccess security thing (assuming i did it right). I changed permissions on my uploads directory to 777 with no luck either.

  7. Arvid
    Member
    Posted 5 years ago #

    interesting - it works with smaller images - ie 750x500 pix, but larger images like 3008x2000 pix fail. maybe wordpress has changed the way it does resizing and now it is more than cheap web-hosting allows the servers to handle for you?

  8. atourgates
    Member
    Posted 5 years ago #

    @arvidtp That might be related to the PHP max file size limit set in your php.ini file.

    Let's see, here's some easy to follow instructions for Drupal - should apply to WordPress too: http://drupal.org/node/97193

    But, that's a different issue (I believe) from what many of the rest of us are experiencing. I can't upload any file of any size, either from Firefox or Safari.

    I'll try internet explorer and see what happens.

  9. atourgates
    Member
    Posted 5 years ago #

    I'll try internet explorer and see what happens.

    Yeah. Turns out IE fails in the exact same way. Browse to an image, upload it just fine, and viola! it's disappeared.

    So, any suggestions?

  10. deadlove
    Member
    Posted 5 years ago #

    I'm having a slightly different but similar problem. I can access the Flash uploader just fine, but when the file completes and goes through the "Crunching..." phase, it gives me a login window rather than the image information. When I check through FTP, the file hasn't actually uploaded at all. Very frustrating:
    http://wordpress.org/support/topic/280337

  11. Arvid
    Member
    Posted 5 years ago #

    @atourgates - thanks for the suggestion, but I already tried setting both post_max_size and upload_max_filesize to 200M with a php.ini file in /wp-admin/
    I'm going to do some more investigation.

  12. Arvid
    Member
    Posted 5 years ago #

    OK - i repent - turns out wordpress 2.7 would not take images that large either on my server. I just thought it had before. Oh well- thankfully there are lots of good image re-sizer freewares out there.

    PS I also tried changing memory_limit in my php.ini file from 8M to 64M, but my host might limit me no matter what i ask for - no idea. In any case it didn't help.

  13. KittyBradshaw
    Member
    Posted 5 years ago #

    Can someone tell me how to go back down to 2.7.1? This is too much... I am not even sure how to begin explainig my problem. I did the automatic upgrade and afterwards the "Visual" view stopped working when creating a post. All the buttons have dissapeared and when I try to upload it produces HTML code written in white.

    *sighs*

  14. estancabigas
    Member
    Posted 5 years ago #

    i had the same problem but the quickpress image uploader was okay. i checked the plugins and found out that click tags is the culprit. mine is now working okay.

  15. Puck
    Member
    Posted 5 years ago #

    I'm also having this problem since upgrading to 2.8. Flash uploader does the "crunching" and then gives me a login screen inside the floating "upload" window for each file I uploaded.

    Latest Flash, Gears disabled, multiple browers (and both Vista and XP), caches cleared and recleared and restarted, js_cache removed, I even rebuilt Apache on the server so it has the latest PHP (5.2.9).

    I've tried everything I can find to fix it, nothing is working.

  16. Anonymous
    Unregistered
    Posted 5 years ago #

    hey guys

    i'v found a solution for uploading image problem , check out this article and follow instructions.

    http://www.ibuyringtones.com/iblog/?p=77

  17. Vast HTML
    Member
    Posted 5 years ago #

    Well just updated to 2.8.1 Beta2 and having the same issue... STILL! ii have to save the post and then upload all the images to get it to work.. This is getting annoying fast haha.

  18. 2thenext
    Member
    Posted 5 years ago #

    Had the Same problem uploading images using 2.8 I deactivated all plugins and added them back one by one and found that Position Yourself plugin was the reason my image uploader was not working. It is working fine now that I deactivated it and now I am about the delete it.

  19. Scarpace
    Member
    Posted 5 years ago #

    TRY THIS...
    If you are using a custom directory to upload your photos in 2.8, there is only one way I found out how to make it work. With a fresh install, in the "Setting/Miscellaneous" under "Store uploads in this folder", I put "uploads" (instead of the default 'wp-content/uploads') and for "Full URL path to files" I put "http://www.mywebsite.com/uploads" then clicked the "Save Changes" button. Then by using a FTP client, I had to CHMOD the Permissions settings for the newly created "uploads" directory to "777" before attempting to upload an new images while adding or updating any posts.

  20. byronedwards
    Member
    Posted 5 years ago #

    I'm also having the same problem as most here with WordPress 2.8 ie. Images won't upload using the flash/or browser media uploader - I get an http error.

    After some testing I've found I can upload a jpeg of 500px x 500px if it's saved around 100kb, but not if it's saved at 200kb.

    So it works after a fashion so long as images have a small filesize.

    Any thoughts?

  21. Laetitia Hoffmann
    Member
    Posted 5 years ago #

    same, same, no difference for me! RAAAAAAA... pulling my hair off!

  22. byronedwards
    Member
    Posted 5 years ago #

    Problem still there for me in RC1

  23. Reine Marge
    Member
    Posted 5 years ago #

    I am having the same problem with 2.8 as so many other WordPress users are.

    Clearly the time to fix 2.8 is here!

  24. rrhobbs
    Member
    Posted 5 years ago #

    image uploader doesnt work - uploads image ok - it is there in the folder but post dislays caption only - works fine if I upload image to an /images directory of my own making and inserting into post w html.

    This is not the usual WordPress "things that just work" that I have come to love.

  25. byronedwards
    Member
    Posted 5 years ago #

    Well I've upgraded to 2.8.1 and it still doesn't work properly. Small files <100kb ok, larger files >100kb give an unhelpful 'http error'.

  26. Sankho
    Member
    Posted 5 years ago #

    I figured out a fix, it worked for me at least. Check out my blog http://blog.sankhomallik.com/2009/07/28/wordpress-28-media-upload-issue/

  27. kp studios
    Member
    Posted 5 years ago #

    I found this not to be related to any plugins. My current workaround was to save the post as a draft before trying to upload any images.

    If someone else could confirm this, that would be great – vineetsharma / da3M0n

    thanks for that tip, it worked a treat

  28. niekvugteveen
    Member
    Posted 5 years ago #

    http://wordpress.org/support/topic/254480?replies=9#post-1155091 Other topics and a possible solution can be found here.

  29. marketing_guy
    Member
    Posted 5 years ago #

    I've had this problem after moving my wordpress installation - it's advisable to check the miscellaneous settings and see where your files are being uploaded to and change accordingly

  30. koolvn
    Member
    Posted 5 years ago #

    I was having same problem with my host but no problem to run same wordpress 2.8 with same theme on my local wamp as well as testing on my friend's free host account. Since I'm running my own web server wamp for developing and testing, I've tried to lower a lot of different server settings in order to duplicate the error. Finally, found out that my wamp is always update to latest version of apache, mysql, and php and my friend's free hosting account is php5 w/ mysql5 while my host still mainly run on php4, and after switching to php5, the problem are gone. Thus, I finally can insert images into post as you can see here in my free templates website

    http://themes.jlbn.net

    So make sure to check with your host if they still runs php4, and ask them to switch to php5 for you ;)

Topic Closed

This topic has been closed to new replies.

About this Topic