WordPress.org

Ready to get started?Download WordPress

Forums

Participants Database
Image Upload Failed after move to Windows Server (2 posts)

  1. pulpandwire
    Member
    Posted 5 months ago #

    After moving to a Windows server, we are seeing the error: There is something wrong with the file you tried to upload. Try another. when trying to upload an image in the back end List Participants page. When trying to upload via the [pdb_record] edit page, it just says the record was updated, but no image is added.

    The image is not making it to the specified path in settings. I've also tried changing this to match exactly to the web path in the error message they sent me instead of just starting with /wp-content/ realizing that the path is case sensitive on the Windows server and not on the LAMP stack which is our dev site. The error the server tech is seeing states "Warning: realpath(): open_basedir restriction in effect. File(C:\Windows\Temp\php3C19.tmp) is not within the allowed path(s): (D:\webfolder)"

    When questioned about the restriction, the server admin on their end stated: "when I remove our basedir restriction it does upload." but apparently this isn't something that can be removed permanently.

    I've tried changing the upload path in the General Settings back to the default setting (as well as other variations back to the root) just to receive the same thing.

    I checked the participants-database.php line of code per your suggestion in this thread: http://wordpress.org/support/topic/photo-upload-not-working and found that realpath() is already added to the line you reference.

    I'm not sure where to go from here and, unfortunately, the migration to the windows server is their live server, so getting this ironed out ASAP is a high priority.

    Any help or insight would be greatly appreciated.

    Thanks.

    http://wordpress.org/plugins/participants-database/

  2. xnau
    Member
    Plugin Author

    Posted 5 months ago #

    Well, this is a little beyond my expertise, but I think it's possible to create an exception so that the open_basdir restriction is lifted to specific directories. This post on Stack Overflow hints at this possiblity.

Reply

You must log in to post.

About this Plugin

About this Topic