WordPress.org

Ready to get started?Download WordPress

Forums

Image Upload Error in 2.5 RC1 (16 posts)

  1. Geezerjim
    Member
    Posted 6 years ago #

    I am getting an html error when I try to upload an image using 2.5 RC1. The permissions are set to 777 on wp-content. The directory "uploads" did not exist and was not created. I tried to create in manually and set the permissions on it to 777 as well. Still no joy.

  2. ditdotdat
    Member
    Posted 6 years ago #

    I am having problems uploading with 2.5 RC1 as well, but only with the Ajax uploader.

    Browsers - Safari 3.0.4 (most recent version) and Mac Firefox 2.0.0.12
    Server - PHP 5.1.2

    The permission on wp-content is 755 but changing it to 777 makes no difference.

    The image uploads OK but when we get to the "Crunching" message I get an error "An error occurred in the upload. Please try again later."

    Here's the error from the PHP error log: mod_security: Access denied with code 403. Error processing request body: Multipart: final boundary missing

    Uploading from IE 7 with no Ajax works fine.

  3. jayvdc
    Member
    Posted 6 years ago #

    this seems to be a common issue. i hope it is resolved soon, 2.5 is amazing.

  4. RyanWilliams
    Member
    Posted 6 years ago #

    My uploads are freezing too and just leaving me with the "Crunching" message. Nothing else happens, and the image is never uploaded. Anyone know what exactly causes this? I could at least request my host adjust their settings in the meantime.

  5. RyanWilliams
    Member
    Posted 6 years ago #

    This worked in my .htacess:

    <IfModule mod_security.c>
    SetEnvIfNoCase Content-Type \
    "^multipart/form-data;" "MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
    </IfModule>
  6. john_nyc
    Member
    Posted 6 years ago #

    thanks ryan! One i made the upload folder and added that code the uploads worked great. I wanted to test the gallery option and it is soooo easy!!

    getpromready.com is my play site for it
    only thing now is to find a way to have the full size image display in an image viewer or attachment.php type page

  7. dfunkydog
    Member
    Posted 6 years ago #

    John

    checkout wp-includes/media.php

    line 27

    // we're inserting a full size image into the editor.  if it's a really big image we'll scale it down to fit reasonably
    		// within the editor itself, and within the theme's content width if it's known.  the user can resize it in the editor
    		// if they wish.
    		if ( !empty($GLOBALS['content_width']) ) {
    			$max_width = $GLOBALS['content_width'];
    		}
    		else
    			$max_width = 800;
    	}
  8. dfunkydog
    Member
    Posted 6 years ago #

    The following solved my problem

    • create uploads folder manually, CHMOD to 775
    • enter Full URL path to files in settings->misc
    • add .htaccess with SetEnvIfNoCase Request_URI PATH-TO-WORDPRESS/wp-admin/async-upload.php$ MODSEC_ENABLE=Off

    hope it helps you out

  9. thanapat
    Member
    Posted 6 years ago #

    I can upload an image by IE6 but keep "Crunching..." on Firefox 2.0.0.3 with HTTP error message.

    After uploading by IE6, I can not manage my image at all. Amazingly I can manage my image on Firefox 2.0.0.3 after that.

    Is this the browser compatible issue?

  10. Rage00001
    Member
    Posted 6 years ago #

    i really hope there is a new update soon, i can't get this to work :(

  11. siilber
    Member
    Posted 6 years ago #

    dfunkydog

    The following solved my problem

    * create uploads folder manually, CHMOD to 775
    * enter Full URL path to files in settings->misc
    * add .htaccess with SetEnvIfNoCase Request_URI PATH-TO-WORDPRESS/wp-admin/async-upload.php$ MODSEC_ENABLE=Off

    hope it helps you out

    Strangely, first image was successfully upload but next one get error after crunching. Then changed htaccess i get internal server error...
    everyone know this ?

  12. monnibo
    Member
    Posted 6 years ago #

    RyanWilliams

    This worked in my .htacess:

    <IfModule mod_security.c>
    SetEnvIfNoCase Content-Type \
    "^multipart/form-data;" "MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
    </IfModule>

    THANK YOU!
    (I also set my CHMOD to 777 from 755 but that may have been unnecessary.)

  13. surfalot
    Member
    Posted 5 years ago #

    If you are a server manager, you can knock this out for everyone with an exclusion in your mod_security config.

    Make an exception for only the offending script(s) in the /usr/local/apache/conf/modsec.user.conf (cPanel server) mod_security config file before any of the rules include files as such:

    <LocationMatch "/PATH-TO-WORDPRESS/wp-admin/async-upload.php">
    SecFilterEngine Off
    SecFilterScanPOST Off
    </LocationMatch>

    <LocationMatch "/PATH-TO-WORDPRESS/wp-content/plugins/nggallery/admin/wp25/upload.php">
    SecFilterEngine Off
    SecFilterScanPOST Off
    </LocationMatch>

    These two files are the default locations of the WordPress flash upload and the NextGEN gallery plugin flash upload scripts. For any other scripts, change the LocationMatch to suit. Hope this help someone.

  14. surfalot
    Member
    Posted 5 years ago #

    My apologies, this should catch it server wide, regardless of the directory WordPress is installed in...

    <LocationMatch "wp-admin/async-upload.php">
    SecFilterEngine Off
    SecFilterScanPOST Off
    </LocationMatch>

    <LocationMatch "wp-content/plugins/nggallery/admin/wp25/upload.php">
    SecFilterEngine Off
    SecFilterScanPOST Off
    </LocationMatch>

  15. twop
    Member
    Posted 5 years ago #

    THIS FIXED MY PROBLEM:

    I was playing with some of the settings that weren't mentioned in any of the posts I found on the forums and was able to fix the problem WITHOUT messing with permissions and safe-mode. When logged into WordPress dashboard(wp-admin url page) I went to settings>miscellaneous. I changed 'Store uploads in this folder' to 'wp-content/uploads' (mine was this by default but I made sure it was this since I read it could cause this problem if it wasn't this), then I unchecked the 'Organize my uploads into month- and year-based folders' box. Unchecking this box and saving the changes is what solved my problem.

  16. paljasken
    Member
    Posted 5 years ago #

    In Miscellaneous Setting i've set the Full URL path, and it now is possible to add files with the browser uploader.
    What seems strange to me is that i don't see the actuals files when i check the uploads folder on my ftp site.

Topic Closed

This topic has been closed to new replies.

About this Topic