WordPress.org

Ready to get started?Download WordPress

Forums

Image upload error: "File is empty. Please..." (9 posts)

  1. thatfan
    Member
    Posted 4 years ago #

    Today I tried to upload a JPG image to my blog and I got the following error:

    "File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini."

    The file I tried to upload wasn't that large, and I've never gotten this error before so I'm confused as to why this is all of the sudden happening. I contacted Godaddy and they said it was a WordPress issue and couldn't help me.

    By the way, I checked PHP.ini and my uploads are not disabled, and my max post size is 8MB. The image I'm trying to upload is only about 45KB, so I don't think php.ini is the problem.

    Any help would be greatly appreciated!

  2. festinhabobanoape
    Member
    Posted 4 years ago #

    I am having the same problem, it happened just after I upgraded from 2.8.6 to 2.9.1 - I also lost all my categories and tags that I am dealing on this other post:

    http://wordpress.org/support/topic/349105?replies=1

    If you have any news over here please let me know...

    Thanks

  3. Sproke
    Member
    Posted 4 years ago #

    I'm having the same trouble as "thatfan". I had originally thought that it was because there was not any room on my server, but I have a 104mb free, and I'm only uploading a 256kb photos. Any body else having this problem?

  4. suneedh
    Member
    Posted 4 years ago #

    I am having the same problem as well. Could anyone Please help us out here?

  5. jcobras3
    Member
    Posted 4 years ago #

    Hello! I just ran into this problem today as well...could someone please assist me with this? Thanks!

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    If this is happening with a single image, try re-saving the image as a standard-encoded .jpg file in a graphics application before re-uploading it.

  7. MiguelOliveira
    Member
    Posted 4 years ago #

    The error is caused by a SQL error. It happened to me recently and found a mistake in a line responsible for the insertion of documents in the table posts. This error appears in the file \ wp-admin \ includes \ file.php (line 280) and in the file \ wp-admin \ includes \ import.php (line 63) (responsible for the import of xml) and despite the SQL script insertion arise later, swfupload returns this error. This can be caused by file name or any other reason. It happened to me, I hope I can help ...

  8. Choja
    Member
    Posted 4 years ago #

    Same problem just began with me...
    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

    WTF??? Is anyone going to tell us how to fix this??

  9. tom_geraghty
    Member
    Posted 3 years ago #

    Same problem here:

    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

    On shared linux hosting, and completely stumped by it right now.

Topic Closed

This topic has been closed to new replies.

About this Topic