WordPress.org

Ready to get started?Download WordPress

Forums

Image Upload Error (17 posts)

  1. RobertPaulson
    Member
    Posted 7 years ago #

    I have to believe this has come up before, but the search term "image upload" came up with nothing.

    I also have to believe this problem is operator error on my part, but I don't know what I need to do.

    I tried to upload an image from the post-new.php page, but only was able to get this error:

    The uploaded file could not be moved to /home/advanced/public_html/wp-content.
    Warning: Cannot modify header information - headers already sent by (output started at /home/advanced/public_html/wp-admin/admin-functions.php:1879) in /home/advanced/public_html/wp-includes/functions.php on line 1219

    Any ideas where I may have goofed, or what I need to do to fix this?

    Thanks in advance.

    P.S. - I'm running version 2.1

  2. Chris_K
    Member
    Posted 7 years ago #

    Unfortunately, our search is broke again...

    Is wp-content writable by the server process?

  3. RobertPaulson
    Member
    Posted 7 years ago #

    CHMOD for the wp-content file is currently set at 755 (if that's what you're asking).

    BTW, wow that was a fast reply.

  4. Chris_K
    Member
    Posted 7 years ago #

    Well, one would certainly think that's adequate...

    However, for grins, (temporarily) set it to 777 and try (and then set back to 755 of course).

  5. RobertPaulson
    Member
    Posted 7 years ago #

    Ok, 777 makes it work. This is a blog I'm setting up for someone far less technically proficient than I, so I don't think I want to leave it at 777 for him (right?).

    Is there a setting I can use to make this secure yet allow the image uploads?

  6. Chris_K
    Member
    Posted 7 years ago #

    Now back at 755? Can you upload another image?

    If so, then visit Options -> Misc and uncheck "Organize my uploads into month- and year-based folders" and you should be good to go. :-)

  7. RobertPaulson
    Member
    Posted 7 years ago #

    Nope - when I change it back to 755, I get the original error.

  8. RobertPaulson
    Member
    Posted 7 years ago #

    Side note - on the Options > Misc page, none of the radio buttons are checked.

  9. RobertPaulson
    Member
    Posted 7 years ago #

    666 also doesn't work.

  10. Chris_K
    Member
    Posted 7 years ago #

    ugh. So you and httpd aren't even in the same group, eh?

    I'm a bit stumped as to what to suggest. Suggesting you leave it at 777 causes me to break out in a bit of a rash.

    Perhaps try a site search here on the topic (like at google with "site:wordpress.org/support keyword keyword2") and see what you turn up?

  11. RobertPaulson
    Member
    Posted 7 years ago #

    Handy - Thanks for all your replies on this. I was able to find several similar threads, but oddly enough, each user ended up changing CHMOD settings to 777 to fix the issue.

    Seems that we don't want to do that, right?

  12. jonwilley
    Member
    Posted 7 years ago #

    Ok, i am having the same issue also... have read ALL of the posts regarding this problem. I am getting the The uploaded file could not be moved to /home/httpd/vhosts/jonwilley.com/httpdocs/wordpress/wp-content/uploads. error. I have had the Host turn Safe Mode OFF and have uploaded my OWN uplaods directory, turned off the month/year option and have Chmod everything necessary to 777. Are there any other thoughts anyone can think of to get my image uploads to work?

  13. RobertPaulson
    Member
    Posted 7 years ago #

    I'm no php coder, so I can't even guess at how this would need to be done, but I know there is forum software out there that runs on php and MySQL that allows for picture/file uploads without having to have folders with a CHMOD setting of 777. As I understand it, the file uploads are part of the DB, not just files in a folder somewhere.

    Looking to the future, I wonder if that is a functionality that could be added to WordPress. Because I'm thinking that most everyone who has any pictures in the WP blogs has some folders CHMODed to 777, which as I understand it is not the most secure setup one can have.

  14. Chris_K
    Member
    Posted 7 years ago #

    Because I'm thinking that most everyone who has any pictures in the WP blogs has some folders CHMODed to 777

    No. Not everyone. It's definitely a host-dependent deal.

    Wish I could be of more help. In this case, I just don't know what to suggest. :-/

  15. RoyalFool
    Member
    Posted 7 years ago #

    I'm also having this problem, right after I upgraded to 2.1 I can no longer upload images to my site. Changing the CHMOD settings to doesn't even seem to be enough, I have no idea what to do.

  16. FritzH
    Member
    Posted 7 years ago #

    i had the sam problem: I threw away both 'uploads' and 'myimages' folders and created a new 'myimages' folder(with my ftp-application) and chmod'ed it to 777. Then set wp-contents temporarily to 777, turned of date-organizing in WordPress and uploaded my first image! It worked! Then I changed WP-content back to 755 and it still works. So I'm confident this is a wordpress bug. Unfortunately i'm not much of a programmer...and the automatic date-organizer still doesn't work...

  17. mikesz
    Member
    Posted 7 years ago #

    This error message usually is caused by white space before the beginning <? or after the closing ?> php tags. Some editors add spaces to the end of the file that shows up as blank lines after the closing tag. You might want to check that in the files named in the error message.

    hope this helps, mikesz

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.