WordPress.org

Ready to get started?Download WordPress

Forums

Image upload doesn't work in subsites (9 posts)

  1. cinematic
    Member
    Posted 2 years ago #

    Hi, in my multisite image upload works fine in the root site, but in the subsites images won't be displayed. The images however are uploaded in the relevant files folder and if I download them to my pc I can view them without any problems, the files don't seem to be corrupt. Nevertheless I can't view them at the direct image url because "they contain an error" Thanks for any tips.

  2. Nevertheless I can't view them at the direct image url because "they contain an error"

    Is that the full error message?

    Did you update your htaccess correctly?

    Can you share URLs?

  3. cinematic
    Member
    Posted 2 years ago #

    The error message is
    The image http://link-to-the-image.jpg cannot be displayed because it contains errors. And if I save this errormessage image to my pc I cannot open it (not a valid picture). But if I download it via ftp I can open it.

    I don't want to post a link because it is not my site, but I can send you the link in a private message if I only knew how I could do this :)

    htaccess settings are correct (copy & paste from the network admin dashboard)

  4. Okay the URL should look like this:

    domain.com/sitename/files/2012/01/image.jpg right?

    Which site NUMBER is this? If it's 2, go to

    domain.com/blogs.dir/2/files/2012/01/image.jpg

    See if that works.

  5. cinematic
    Member
    Posted 2 years ago #

  6. 1) Check your .htaccess (is it the right one for subfolder?)

    2) Check your httpd.conf (is allowoverride set to all?)

  7. cinematic
    Member
    Posted 2 years ago #

    The site is on a shared hosting environment so I am afraid I cannot access httpd.conf.

    This is my .htaccess (as it is displayed in the network configuration for subfolders)
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

  8. Then ask your webhost to check for you. the .htaccess looks okay.

  9. cinematic
    Member
    Posted 2 years ago #

    ok I will try to solve it with the hoster. Thanks for your support.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.