WordPress.org

Ready to get started?Download WordPress

Forums

Image Upload CHMOD Problem (12 posts)

  1. mliving
    Member
    Posted 9 years ago #

    Ok I've enabled Uploading and when I try and using the feature I get an error message that states:

    It doesn't look like you can use the file upload feature at this time because the directory you have specified (/export/webroot/users/c/cupesudbury/cupesudbury.org/wp-content) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.

    This is the correct folder (according to the WordPress install) but when I change the CHMOD of the /wp-content folder it disables my plugins.

    I got this working on my LAN at home but my remote host is obviously setup differently.

    Any suggestions would be greatly appreciated.

    mliving

  2. First, try a different folder other than /wp-content/. For example, create an /images/ folder and use that. If you still have trouble uploading to that folder, set its permissions to 777 (CHMOD 777).

  3. mliving
    Member
    Posted 9 years ago #

    That seems to have solved the problem.

    As always much thanks!

    mliving

  4. iddapidda
    Member
    Posted 9 years ago #

    My friend is having the same problem, the same error comes up, yet the permissions are 777. Also she has created another folder but still comes the error.

    Any other ideas?

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Are you certain that the folder you think is going to be used is the one WP is trying to use ?

  6. iddapidda
    Member
    Posted 9 years ago #

    Yes, all folder settings are correct. Mindboggling..

  7. dagnast
    Member
    Posted 9 years ago #

    yes podz, it is the same folder...
    same error as the one who started this thread gets...

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Can you post here the path WP is looking at and the url you are looking at too ?

  9. dagnast
    Member
    Posted 9 years ago #

    /kjanaprik.is/dagbok/wp-images/upload

    and

    http://kjanaprik.is/dagbok/wp-images/upload/

  10. dagnast
    Member
    Posted 9 years ago #

    stupit little thingy!

    I tried one little trix that I had tried before and then it didn't work... to add /webs/ infront of the first line in my last post...

    anyways it works now!!! :)

  11. condi4prez
    Member
    Posted 8 years ago #

    Isn't it dangerous from a security standpoint to CHMOD your entire uploads directory and subdirectories to 777?

  12. yosemite
    Member
    Posted 8 years ago #

    Generally not on modern shared hosting. Just don't put your plans to rule the universe in there (or your other top-seekrits).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags