WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] image upload (39 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    image upload

  2. sri
    Member
    Posted 10 years ago #

    Is your question how to do image uploading? In your WP admin page, clk on 'File uploads', set use_fileupload to 'true', set the fileupload_realpath, fileupload_url. You may want to change fileupload_maxk to 2048. I left fileupload_minlevel to 1 and fileupload_allowedusers to 'admin'. Update the settings and go to yourblog/wp-admin/upload.php and upload your images.

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    I can not make this feature work. To be specific, when uploading it goes through the process and also creates the correct path in the source link, but it never uploads the file (even though it tells me it did).
    I tried varying the true path name, thinking I made an error there, but no success.
    For now I upload the image manually but generate the code for the post via WP.
    I've seen nobody else having problems with this, I'm stumped.

  4. Loota
    Member
    Posted 10 years ago #

    I am.
    I've gotten the most recent upload.php build, double-checked the options and relaxed all the permissions, too.

  5. IsraelBarros
    Member
    Posted 10 years ago #

    I have the same problem, what can I do?

  6. Lilandra
    Member
    Posted 10 years ago #

    hi, i know this might be a stupid question, but did you create the images folder that it uploads to?
    if it says it's uploading to http://yoursite/blog/images do you actually have an images folder there?

  7. wbragg17
    Member
    Posted 10 years ago #

    Usually hate me, too posts, but:
    me, too.
    It seems to go through the process, indicates success, no image in post nor folder. There have been other threads mentioning this problem, and given the others response, you are not the only one.
    But overall, wordpress is just such a great application, and still in development, so I just do it using ftp, and image tag.
    William
    http://WilliamBragg.com/wordpress

  8. Lilandra
    Member
    Posted 10 years ago #

    oh, so yours does have the image folder?
    because i had forgotten to make the directory and it had pretended to me that it uploaded it to the directory which didn't exist...
    i'd felt so stupid :(

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    Yes, directory exists. I also tried with relaxing permission. Probably sounds pathetic, but I'm "glad" to hear that I am not the only one with this specific problem, makes me feel less dense. I'll just handle it via ftp - the WP photo hack works just fine, and I might go for only using that - sofar the image upload was used for these odd end things which didn't seem fitting to use the photo hack for and for those cases the ftp upload isn't a biggie.
    With b2 I used a hack which I liked, which created a thumbnail on the fly. I might try incorporating that one into it, though the current one had a lot of visual similarities to that hack, so it might already be based on the same one.
    Still seems weird as the image upload now does to work for some, but not for others - which makes me guessing, it is all the same something with the true path, which I just set to "/images" (also tried "/images/" for good measure, I even tried "images") as the folder called 'images' resides on root level within my domain.

  10. Lilandra
    Member
    Posted 10 years ago #

    do you have your realpath and your url set right?
    like um
    fileupload_realpath: /home/(user_name)/public_html/images
    fileupload_url: http://yoursite.com/images
    i really wish i could be more help...

  11. Anonymous
    Unregistered
    Posted 10 years ago #

    I went through the process again trying to make it work and when there was still no go, I then had the (finally) glorious idea to log in via SSH and locate an image file which had been already uploaded into the images folder to ensure I get the correct realpath. Then it finally dawned on me - I am not in a 'standard' setup with a /home/usr/public_html/ setup but I am setup as a user on that server where /home/ corresponce to a directory called "WebSites" and after changing that, it finally - worked!
    Thanks for your suggestions, it made me - look again ;-)

  12. Lilandra
    Member
    Posted 10 years ago #

    YAY!!!
    so it was your realpath or something
    i'm glad it got working
    now if only someone could direct me to figuring out my problems :)

  13. IsraelBarros
    Member
    Posted 10 years ago #

    I have the same problem, its cool!!

  14. Lilandra
    Member
    Posted 10 years ago #

    So, is it fixed now?

  15. Anonymous
    Unregistered
    Posted 10 years ago #

    If it is fixed for you, I am assuming that your WordPress is hosted on a Mac OS X server and the WebSites folder gets used by you or your ISP as home folder for the various domains.
    Lilandra, yes, it was a realpath issue.
    I'd love to be able to help you with your problem you mentioned, but as I don't know what it is, I don't know ;-)

  16. Lilandra
    Member
    Posted 10 years ago #

    it's the RSS feed...
    but i'll have to get back to you on that..i'm updating
    *fingers crossed*

  17. Anonymous
    Unregistered
    Posted 10 years ago #

    (Raises hand) ME too :-(
    I've checked and double-checked both my paths and permissions. the script goes through the motions and appears to upload the image, but the file is never actually written to the directory...

  18. sam_wilson
    Member
    Posted 10 years ago #

    Aught one post when one has nothing useful to say? I shall this once, but prehaps someone could clarify that point for me? I am experiencing the problem identified above, namely that I am unable to upload images with the 'upload file/image' function. I have check and tried every different value for fileupload_realpath and fileupload_url without success. Apologies for yet another 'me, too' post.
    -- Sam.

  19. Anonymous
    Unregistered
    Posted 10 years ago #

    Well Sam... The only reason I posted a "me too" above is that often, one problem post indicates a specific user/server error. Many posts with the SAME problem might indicate a script bug... So imho, "me too" posts are helpful in this case

  20. Loota
    Member
    Posted 10 years ago #

    path: http://theloo.org/home/my user-name/public_html/images <-- shown this way in the server control panel
    url: http://theloo.org/images
    I've tried every permission combination and still get this message with the latest build:
    [blockquote]It doesn't look like you can use the file upload feature at this time because the directory you have specified (http://theloo.org/home/my user-name/public_html/images) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.[/blockquote]
    So this is a clarification 'ditto' to the 'me too'. LOL.

  21. OperaManiac
    Member
    Posted 10 years ago #

    make the folder in the wp-admin folder and u wont need to specify any path... just make the folder writable.

  22. Lilandra
    Member
    Posted 10 years ago #

    Loota, I think your path has to be /home/my-user-name/public_html/images
    without theloo.org
    at least i hope so...

  23. Anonymous
    Unregistered
    Posted 10 years ago #

    If you write as realpath: http://theloo.org/home/my user-name/public_html/images it will definitely not work. The realpath would seemingly in your case be /home/your user-name/public_html/images. The realpath does never begin with an http (as far as I know).

  24. OperaManiac
    Member
    Posted 10 years ago #

    @loota:
    just make a new folder in wp-admin and chmod it 777
    specify that folder in the options as it is without any path...
    my folder is in the folder wordpress is installed. and the path is:
    ../upload
    its chmoded 777 and it works fine...

  25. Loota
    Member
    Posted 10 years ago #

    I must be such an idiot.
    I tried both, every which way but Sunday. The directorys are all at chmod 777 except for public_html...
    I'll come back to this later, it's got me frazzled! Thanks anyway.

  26. Lilandra
    Member
    Posted 10 years ago #

    hi Loota
    1) the directory you specify, for the *true path* shouldn't have the http in it, it should just be :
    /home/(username)/public_html/blog/wp-admin/images
    like mine is, real_path: /home/lilandra/public_html/wpress/images
    and the url is http://lilyanddragon.com/wpress/images
    2) you're storing your images in your admin folder?
    at least...that's what i think...
    (and i could be wrong)
    i know! take a screen cap of your file uploads page settings (just white out your username with paint or just clear the username before you take the picture) and post a link to it?

  27. Anonymous
    Unregistered
    Posted 10 years ago #

    The good news is that tonight I got the paths right and it initially appears to be a successful upload. The bad new is that only a red X appears and the image is not actually in the directory.
    WP File upload options: Screen Cap 1
    Server Folder Chmod and hierchy settings: Screen Cap 2
    Thanks for your time.

  28. Loota
    Member
    Posted 10 years ago #

    Sorry...
    Server folder Chmod: #2

  29. Lilandra
    Member
    Posted 10 years ago #

    i don't know, i'm sorry :(
    maybe someone else will have a better idea
    but you can ftp to that folder right?

  30. OperaManiac
    Member
    Posted 10 years ago #

    its not that fun! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.