WordPress.org

Ready to get started?Download WordPress

Forums

Image upload (15 posts)

  1. Mark (podz)
    Support Maven
    Posted 10 years ago #

    The version of WordPress I'm using is the latest download.
    Image upload is set to true.
    Images are accepted for upload, and the program says the file is uploaded. But it isn't.
    I get no error reports regarding permissions, and they are set correctly.
    I've checked and double checked my path setting, and tried with and without a trailing slash.
    The desination folder has been tried with with permissions of 755/766/777.
    I have checked this forum for similar reports, but none seem to fit or work.
    Any ideas anyone ?

  2. Dougal Campbell
    Member
    Posted 10 years ago #

    Double-check your fileupload_realpath and fileupload_url options. If you're sure the values look correct, make sure they don't contain any stray trailing whitespace.

  3. Mark (podz)
    Support Maven
    Posted 10 years ago #

    path is
    /home/websitename/mainwebsite_html/
    url is
    http://www.tamba2.org.uk/images
    I've tried adding images and images/ to the path but no joy....
    path is as reported by my site control panel, and my ftp program also.
    I've just checked, and I've no trailing slash ..
    It's probably something ever so simple too ............

  4. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Okay .. just to test things, I created a new directory on the server, set the permissions to 755 / 766 or even 777, and still get nothing.
    I still get a success message, but no image lands into the server.
    I've even checked my firewall, but the explorer program has full permissions, and I see no blocked entries.
    I'm betting now that it's a problem with my end...

  5. dshupp
    Member
    Posted 10 years ago #

    I've got the same problem with 1.0 and now with 1.0.1..nothing shows up on the server, but I get this in the server error log when I try to upload:
    <pre>[Fri Jan 16 22:49:41 2004] [error] [client 194.196.100.86] File does not exist: /var/www/hosts/www.chinesetriad.org/wp-images/bgbookmarklet3.gif
    [Fri Jan 16 22:49:41 2004] [error] [client 194.196.100.86] File does not exist: /var/www/hosts/www.chinesetriad.org/error.php
    </pre>

  6. HateSpitLove
    Member
    Posted 10 years ago #

    I had the exact same problem until I discovered that the path was not my true path since I was being virtually hosted. Someone posted a php file awhile back that discloses your true path. As long as I am with compliance with forum rules you can download it here, otherwise an admin is free to edit my post.
    http://www.hatespitlove.com/temp/absolutepath.zip
    Just upload it to your upload folder, and type the path to the php file in your browser.

  7. dshupp
    Member
    Posted 10 years ago #

    nice find, my real path was wrong. Now I'm getting:
    Image Details:
    name: DanGuestbook.jpg
    size: 0 KB
    type: image/jpeg
    still no image, still no errors

  8. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Re the above, I'm not virtually hosted, and I have 2 forums and have recently had b2 / Nucleus / MT running (all not to my liking btw) sitting there. I'm confident that my paths are correct.
    Okay.. new day, and my error log was empty, so I viewed my site once, then tried to upload one image once.
    My server error log shows the following; (IP obscured by me)
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] [client 217.155.xxx.xxx] File does not exist: /home/virtual/site97/fst/var/www/html/T2/wp-admin/wp-includes/b2.css
    [error] [client 217.155.xxx.xxx] File does not exist: /home/virtual/site97/fst/var/www/html/T2/wp-images/bgbookmarklet3.gif
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] [client 217.155.xxx.xxx] File does not exist: /home/virtual/site97/fst/var/www/html/T2/wp-admin/wp-includes/b2.css
    [error] [client 217.155.xxx.xxx] File does not exist: /home/virtual/site97/fst/var/www/html/T2/wp-images/bgbookmarklet3.gif
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] get_settings: Didn't find setting comment_allowed_tags
    [error] [client 217.155.xxx.xxx] File does not exist: /home/virtual/site97/fst/var/www/html/pix/tattoo.jpg
    I followed the install instructions, so does this shed any additional light on the matter ?
    Many thanks!

  9. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Absolute path checked, and is correct (thanks for that file!).
    If I upload a pic by ftp, it displays.
    If I upload through wp, I see this in the popup;
    File uploaded !
    Your file iameye2.jpg was uploaded successfully !
    Here's the code to display it:
    Image Details:
    name: iameye2.jpg
    size: 43.84 KB
    type: image/pjpeg
    But it's not there :)

  10. dshupp
    Member
    Posted 10 years ago #

    My error log shows the same missing /wp-admin/wp-includes/b2.css and /wp-images/bgbookmarklet3.gif, but not the other errors.
    Hope this can get working...it's a spiffy feature.

  11. debwire
    Member
    Posted 10 years ago #

    I've had the same consistent problem and I'm still using .72.

  12. amoen
    Member
    Posted 10 years ago #

    @ podz
    i've had the same error... BUT thats because i really thought i had the right real-path... turned out i didnt. the path that ws-ftp AND the Control Panel showed me wasnt the correct one.
    this i found out when i hovered over the upload directory in the File Manager of my Control Panel.
    an adress occurred in the statusbar (bottom) of my browser (IE6)... it showed me the actual real-path i now use... and it workes!
    the only stupid thing is that WordPress doesnt notice the fact that my first path was wrong and simply stated the upload was a succes... when it wasnt!
    greetz,
    jeroen

  13. dshupp
    Member
    Posted 10 years ago #

    OK, so since my webserver is running chrooted, I tried using the non-chrooted, full path, and it worked. however, the result page still tells me that my file size is 0 KB, maybe a bug there.
    Why does this work? how can php possibly know that it's running in a chroot? in addition, this directly conflicts with the info returned from realpath(".") and getcwd(). This kind of makes me angry.
    Also the misreporting bug is in upload.php at the "@unlink($img1);" line. It just unlinks the failed file and doesn't report the failure.

  14. dshupp
    Member
    Posted 10 years ago #

    Also, right now file upload works in ie but not on mozilla firebird 7.0 right now.

  15. Anonymous
    Unregistered
    Posted 10 years ago #

    @amoen
    I've just tried again, no joy.
    I've now tried the full path as defined by the zip program (see way above) , and the path as reported by hovering like you said (which wa the same as my original).
    I'll talk to my server host later today, and see if she can throw any light on the matter.
    Thanks for your reply though.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.