WordPress.org

Ready to get started?Download WordPress

Forums

Image up-loader asks me to log-in again. (12 posts)

  1. OliverC
    Member
    Posted 6 years ago #

    Hello Everyone,

    I recently upgraded my blog to WordPress 2.5. I followed the instructions very carefully and I am having a problem. The problem I am having also existed before I upgraded when I was using WordPress 2.3. I was hoping the upgrade would fix things but the issue the same. Maybe someone can help me figure out what's going on and how to fix it?

    I am in the Visual Editor, I click Add an Image, the upload box appears. Next to "From Computer" I browse and select an image to upload. When I click upload the WordPress admin log-in screen appears inside the upload area! This should not happen... I put my password in again. The next time I try to upload the same image it almost works, I see the thumbnail in the upload browser however I get the error: Specified file failed upload test. Then if I choose to insert the image the upload box goes white and nothing happens. I have to close the box without success.

    I am able to insert images using the HTML editor and tags referencing external images.
    I am on Mac OSX Leopard using the latest version of Firefox 2 and Safari.

    My blog is:
    http://www.thingstocome.com/blog

    I run another blog, also with WordPress and on the same ISP (different servers) and I do not have the same problem.

    Does anyone have some advice? I'm stumped and I lived with this problem for too long now.

    Thank you very much,
    Oliver

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Try clearing your browser's cookies. Might work.

  3. OliverC
    Member
    Posted 6 years ago #

    Sorry that didn't work. I cleared cookies and cache but still the same problem.

    Any other ideas?

  4. OliverC
    Member
    Posted 6 years ago #

    Hi Everyone,

    I thought I would "bump" this message to see if anyone else can help me?

    Thank you.

  5. klipski
    Member
    Posted 6 years ago #

    I just had the "please log in again" problem:
    http://wordpress.org/support/topic/169771

    For me (using Firefox on Windows), it turned out that the "please log in" window was an IE window and once I had logged in via IE, uploading worked.

    I wasn't having the other uploading issues you're having, but this might at least be a helpful clue.

  6. ronchicago
    Member
    Posted 6 years ago #

    i get this issue only when i am working on another computer which made it seem like a cookie thing. eventually i went and logged in again via the upload window and the problem went away.

    this is the case for a site that is v2.3.3 and one that is v2.5

    i came away thinking that wp wanted to make sure i was who i said i was while on a strange computer.

    i am on a mac using FF.

  7. bugle
    Member
    Posted 6 years ago #

    I have this same problem but the upload fails even if I log in, it just places the blog frontpage in the upload window. I thought it may be a conflict with other image plugins like photopress but doesn't look like it...

  8. dane534
    Member
    Posted 6 years ago #

    Now I'm having the same problem. If I'm working in Firefox, I have to also log in separately with IE in order to add an image. If I don't I also get the same "log in" screen.

    Strange that I was adding images just fine two days ago ... not sure what changed.

    Was this issue ever resolved?

  9. jbickers
    Member
    Posted 5 years ago #

    FYI, I'm having the exact same issue on one of my sites - and it's definitely not what ronchicago suggests, as it does the same thing on three different computers (two XP, one Mac), including my home computer.

  10. Alex Dunae
    Member
    Posted 5 years ago #

    I'll add my name to the chorus.

    We're getting the exact same issue on two separate computers (Windows and Mac)

  11. novada
    Member
    Posted 5 years ago #

    I am having the exact same issue. I have been since I switched to 2.5 a few months ago. Last time I fixed it by manually creating the folder for the current month eg. uploads/2009/09 on the server with filezilla. Obviously this "fix" only lasts for a month. Anybody know why this happens and how to fix it?

  12. novada
    Member
    Posted 5 years ago #

    I upgraded to 2.6.1 and the problem described above (that I was still experiencing after upgrading to 2.6) went away.

Topic Closed

This topic has been closed to new replies.

About this Topic