WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Image tool saves with wrong permissions (6 posts)

  1. Eccola
    Member
    Posted 2 years ago #

    My client wants to use the image tool for cropping and scaling. The tools works nice, but saving causes the file permissions to change from 644 to 600, so the scaled images don't show up in media library anymore and the images are not usable. What can I do for the tool saving with wrong permissions? Sure I can change the permissions on server but that is not an option. Is there a function that solves the permissions on saving from image tool?

    Thank you for any info.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    That sounds like a file ownership issue. You may have to ask your hosts for assistance with this.

  3. Eccola
    Member
    Posted 2 years ago #

    Thanks, esmi,
    the files are still owned by the site owner, only the permissions change from 644 to 600 at saving time, so I can't see the images at the backend. I am the 'host' of the site, I have root privileges to server. Everything works nice, uploading, updating, auto-installing etc. Upload directories permissions are set 755.

  4. keyone
    Member
    Posted 2 years ago #

    anyone figure this out? i have the same problem!

  5. keyone
    Member
    Posted 2 years ago #

    just found the answer here...basically, you uncheck the box under media settings to organize images into year/month subfolders.

    http://wordpress.org/support/topic/image-upload-unable-to-create-directory-777-does-not-work?replies=6

  6. Eccola
    Member
    Posted 1 year ago #

    This happened to me only once on badly configured webserver.
    keyones solution is not acceptable. We absolutely want to organize the images by year/month!
    Marked as resolved 26.10.2012

Topic Closed

This topic has been closed to new replies.

About this Topic