WordPress.org

Ready to get started?Download WordPress

Forums

Image Title Disappears after Upload and Initial Edit (11 posts)

  1. WebmasterT
    Member
    Posted 1 year ago #

    There are currently two problems with uploading images into WordPress.

    Two WordPress versions back (when the new upload image interface was introduced) these two problem began occurring.

    PROBLEM 1:

    1. You upload an image.
    2. You place a title in the "Alt Text" box and the "Title" box after the upload has been completed.
    3. You click "Insert into Post".
    4. The image appears in the post.
    5. You hover over the image and click "Edit Image".
    6. The image appears on screen to be edited but the title you placed into "Title" after the upload has disappeared.

    Why is this?

    This never happened two WordPress versions back. This problem or error means you have to do more work titling an image.

    Previously, you:

    1. uploaded an image.
    2. You placed a title in the "Alt Text" box and in the "Title" box after the upload had been completed.
    3. You clicked "Insert into Post".
    4. The image appeared in the post.
    5. You hovered over the image and clicked "Edit Image".
    6. The image appeared on screen to be edited with the title you placed into "Title" and "Alt Text" after the upload.

    PROBLEM 2:

    The title you placed into "Title" and "Alt Text" also stayed in their places if you created a new post and inserted a previously uploaded image into it. Now when you insert a previously uploaded image into a new post, the title placed in "Title" from the previous upload disappears.

    Why is this?

    This all started with the new image/media upload screen introduced two versions back.

    I upload images into every post I publish and this adds serious time to post creation when I have to label a image's "Alt Text" title in one session, close it then open it up again to title the image's "Title".

    Please help. Please fix this bug, error or whatever it is.

    Hosting environment: My host is Hostgator. I started using Cloudflare a month and a half ago.

    Prominent site plugins: Yoast WordPress SEO, WP Super Cache, Robots Meta, Google XML Sitemaps, Disqus Comment System, and Hotfix. I use other plugins as well.

    Theme: custom made.

    URL: http://film-book.com

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Can you replicate the problem using the default 2012 theme with all plugins deactivated?

  3. WebmasterT
    Member
    Posted 7 months ago #

    How can using Twenty Twelve with all plugins deactivated replicate the problem?

  4. esmi
    Forum Moderator
    Posted 7 months ago #

    Because I have been unable to replicate your problems.

  5. WebmasterT
    Member
    Posted 7 months ago #

    Esmi:

    I did as you asked. I used Twenty Twelve and deactivated all plugins.

    Directly after the image upload was complete, I typed a name into "Title" and "Alt text." After that, I clicked "Insert into Post."
    When I did so and hovered over the image, the name I typed in did not appear in a yellow square over the image. I clicked "Edit Image" and when the new screen appeared, the name I had typed into "Title" had disappeared.

    Try it yourself and you will see.

    Try this as well: upload an image into a post, publish it, start a new post and insert that same image. Click "edit image." The information you previously typed into "Title" will have disappeared.

    This never happened with the previous image upload system.

  6. esmi
    Forum Moderator
    Posted 7 months ago #

    Are you still using WordPress 3.5.1? If so, why? Were you aware that your site is currently running a very real risk of being hacked? You need to upgrade WordPress asap.

  7. WebmasterT
    Member
    Posted 7 months ago #

    We are running 3.7.1. We have been since the upgrade became available.

  8. esmi
    Forum Moderator
    Posted 7 months ago #

    Then I definitely cannot replicate your problem. I followed the steps you gave above on one of my 3.7.1 local installs and I didn't get any change in the alt text of the uploaded/edited image.

  9. WebmasterT
    Member
    Posted 7 months ago #

    You will not see a change in the name you place in "Alt Text". You will see a change in the name you place in "Title". It will disappear.

  10. WebmasterT
    Member
    Posted 6 months ago #

    Esmi:

    I made this video on YouTube to illustrate both problems as my words seem to be falling short.

    Please watch it: http://youtu.be/lYA8IHTzgCM and tell me if these two problems (errors) can be fixed.

    Thank you.

  11. WPyogi
    Volunteer Moderator
    Posted 6 months ago #

Topic Closed

This topic has been closed to new replies.

About this Topic