WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox Plus Colorbox
Image title as overlay caption (9 posts)

  1. Bryan Hoffman
    Member
    Posted 9 months ago #

    I'm not sure which WP update changed this (most likely 3.6) but the image title is no longer being used for the overlay image caption when using LPCB for WP Galleries.

    Looking at the source, each image link title is being returned as the title of the post.

    Thanks,
    ~ Bryan

    http://wordpress.org/plugins/lightbox-plus/

  2. Bryan Hoffman
    Member
    Posted 9 months ago #

    For reference, here's a screenshot of what I mean...

    http://spig.io/image/0f0x2Y3n340P

    The link title should be the same as the alt title on the image... "Bees Game" is the title of the post.

  3. KennyLL
    Member
    Posted 9 months ago #

    Also want to watch this issue. I noticed it in 3.7.1, may have been OK in 3.6. Displays post title for every image, definitely not as elegant.

    Can use captions, but then they show up under thumbs on page - also not elegant.

  4. photoMaldives
    Member
    Posted 9 months ago #

    A-ha ! I've got this problem too - I thought I'd made an error somewhere, as it certainly used to work OK.

    I have the correct Caption/Alt-text/Description filled in on the media page, but the lightbox now pulls in the post title.

    Example - using a WP gallery - the name of the POST shows at the top of each photo (and doesn't change for each of the 6 images) -
    [gallery link="file" columns="6" ids="5845,5846,5847,5852,5853,5854"]

    Interestingly, using the NextGEN gallery - the name of each IMAGE is displayed correctly -
    [nggallery id=33]
    (however this is not a good workaround as the NextGEN lightbox also appears underneath!)

    Anyone else with a fix/workaround ?

  5. @photoMaldives Per the forum welcome please post your own topic.

    http://wordpress.org/support/plugin/lightbox-plus#postform

  6. photoMaldives
    Member
    Posted 9 months ago #

    OK - sorry, Jan - I'm confident it's the same issue, and thought I was adding to the discussion. However I've started a new thread anyway -

    http://wordpress.org/support/topic/lightbox-displaying-post-title-instead-of-image-name-1

    (even though it's not showing up ? Are all posts held in a mod queue nowadays ? If so, apols again - I just posted twice !)

  7. lynnema
    Member
    Posted 8 months ago #

    Hi all -

    I think I found a solution - here is my post on the same topic...

    http://wordpress.org/support/topic/issue-with-page-title-overlay-title?replies=2

    Seems to be working for me. Hope this helps!

  8. photoMaldives
    Member
    Posted 8 months ago #

    Thanks for the headsup, lynn/jess :-)

  9. KennyLL
    Member
    Posted 8 months ago #

    I can also verify that the second solution (smaller one) in the final link does work here. It picks up the title of an image if there is one, or reverts to the Post title if the image title is left blank. The alt text shows up on the thumbnail, but is stripped out on the lightbox pop-up image.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.