WordPress.org

Ready to get started?Download WordPress

Forums

Image Thumbnail link drops my domain in FF? Help! (4 posts)

  1. kjandb
    Member
    Posted 6 years ago #

    When you try to view my pictures in firefox, the domain name gets dropped from the link. My site is kjbradshaw.com

    First off, the thumbnail doesn't even show up...it just has the filename as the link. Then, once you click it, it directs you to http://wp-content/uploads/2007/11/idahosturgeon3.jpg which doesn't even include my domain name????? Any ideas?

    Seems to work fine in IE so I don't understand why links would be different in two browsers.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Your post content is your own. Your links look like "////wp-content/uploads/etc...". That's not correct.

    The reason it seems to work in IE is because IE is interpreting that incorrect URL in a way that allows it to work. Firefox is more strict.

    Just edit the links and img src bits in the posts to be correct and to have the full HTTP and such there. They should not start with "////", they should be "http://kjbradshaw.com/wp-content/etc.."

  3. kjandb
    Member
    Posted 6 years ago #

    So I need to edit every post? Is there a way to permanently fix it? Did my hosting mess it up during installation?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Well, I can't tell you that information. I don't know how you created those bad links and images in the first place.

Topic Closed

This topic has been closed to new replies.

About this Topic