WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Image Sizes Not Working After Update to 2.0.6 (12 posts)

  1. tokkilee
    Member
    Posted 1 year ago #

    Have a client site located here: http://101.0.78.218/~mygymbag/ and after the update to 2.0.6 which I think updated some image stuff) none of the category images are getting resized or cropped properly, either from the custom sizes set in WC in the admin, nor the custom sizes set in functions.php. You can even see where the correct image dimensions are getting set in the image tag, but not the correct image crop itself, resulting in distortion. This has also happened in the upcoming sales calendar in the right hand bar.

    Note that this is only effecting the category images and nothing else?? All the other images work fine. Have tried regeneration several times as well.

    http://wordpress.org/extend/plugins/woocommerce/

  2. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    What settings are you using in settings > catalog? Specifically crop for the catalog size (which should be used here):

    https://github.com/woothemes/woocommerce/blob/master/woocommerce-template.php#L1219

  3. tokkilee
    Member
    Posted 1 year ago #

    These are my settings here: http://awesomescreenshot.com/05915kpq2a

    I haven't changed any core files, and even reuploaded the plugin from the test site (which was working bc I didn't regenerate)

  4. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    Those catalog settings are not square, but you are displaying them square on your site..if your issue is that they look squished surely that's the reason?

  5. tokkilee
    Member
    Posted 1 year ago #

    And this is why I shouldn't code on one hour of sleep - sigh

  6. tokkilee
    Member
    Posted 1 year ago #

    Actually, no wait. They're not square. They're 284x240. Which is what the settings are to, but the images are squished.....

  7. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    Odd, look at this: http://cl.ly/image/13350V1Y0a1T

    Does your template use the catalog image size when loading the thumbnail? Does that natural size look familiar?

  8. tokkilee
    Member
    Posted 1 year ago #

    That's what I'm saying - it's not loading the proper image --- it's giving it the full size image while loading the correct height,width dimensions inside of the tag itself....searched the site for the width="284" just in case I had hard coded it somewhere (I coded this site FOREVER ago) but it's no where, so I believe it's using the standard wc hook - so shouldn't it be taking the correct size?

  9. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    I know its using the right dimensions on the tag, bug the actual image size is not the resized version - its full. Are you definitely sure you've used the regenerate thumbnails plugin on this site? Look for Lurv-284x240.png in your wp-uploads folder.. should be there if the sizes were generated.

  10. tokkilee
    Member
    Posted 1 year ago #

    Yep I've done it several times. The image dimensions haven't been changed at all, I just moved the site from one server to another (and updated WC).

  11. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    Yeah, but I think the image size names might have changed in 2.0. Not sure. Can you do it again anyway ;)

    Also, did the image exist or not?

    Should probably take a quick look at the theme too if you want to email it to me to check (mike.j@woothemes.com).

  12. tokkilee
    Member
    Posted 1 year ago #

    Right it didn't save at all - what are the new image size names and where would I change that? Will zip and email you theme real quick

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic