WordPress.org

Ready to get started?Download WordPress

Forums

Image not showing up in Posts (8 posts)

  1. rrdasgupta
    Member
    Posted 9 months ago #

    Find it hard to believe that I need to learn how to tweak .php code to get a simple resolution. Can I get some straight answers and insights on where I may be going wrong. I am not a techie so I need simple English problem resolution which I am sure the world class WordPress community can provide. So far what I have studied are really adventurous tech conversations which I do not understand. Please help:
    Problem: Image does not show within posts whether viewed in IE 11, FireFox or Chrome. Image has loaded into Image Gallery and has been associated with the post (see below)
    Site address : http://rrdasgupta.com
    Post url : http://rrdasgupta.com/?p=1251
    Image url : http://rrdasgupta.com/wp-content/uploads/2013/11/Loy-Mendonsa-Search.png

  2. rrdasgupta
    Member
    Posted 9 months ago #

    BTW, going by some popular advice I have also cleared my cache in all browsers. Does NOT work still :(

  3. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    The URL for that image on your site is this:

    http://i2.wp.com/rrdasgupta.com/wp-content/uploads/2013/11/Loy-Mendonsa-Search.png?resize=900%2C498

    And that shows this message for me:

    We cannot complete this request, remote data could not be fetched

    Did you upload the image to your media library?

    Looks like possibly a JetPack issue? Try deactivating your plugins to see if that makes a difference.

  4. rrdasgupta
    Member
    Posted 9 months ago #

    Thanks much WPYogi: So should I just deactivate Jetpack plugin
    Yes I had uploaded my image to the Image Library and then invoked into it within my post
    I obviously need Akismet and All-in-One SEO to be there
    I had kept these as bare minimum plugins
    Kindly advise

  5. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    Try deactivating JetPack, yes.

  6. rrdasgupta
    Member
    Posted 9 months ago #

    Yes I disabled JetPack and the image shows up within the main post
    It does not however show up in the snippet on my home page - http://rrdasgupta.com/- what could be going wrong?
    Also kindly suggest plugins that can make up for Jetpack
    Thanks much once again for your very prompt counsel- Grateful

  7. rrdasgupta
    Member
    Posted 9 months ago #

    Also if I try to change my permalink structure to a post extension then it does not work. And with the current permalink the image does not show up either on Facebook or LinkedIn. Kindly advise

  8. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    It does not however show up in the snippet on my home page - http://rrdasgupta.com/- what could be going wrong?

    I'm guessing that your theme is using excerpts and/or that you need to set that as a featured image. Theme specific help is on the theme's own sub-forum here:

    http://wordpress.org/support/theme/montezuma

    So you could try there.

    You could try activating just the modules of JetPack that you really want - as it may be that only certain parts are troublesome -

    http://jetpack.me/support/#turn-off-jetpack-modules

Reply

You must log in to post.

About this Topic