WordPress.org

Ready to get started?Download WordPress

Forums

Image Not Clickable (17 posts)

  1. BUSA
    Member
    Posted 5 years ago #

    Since the time i have upgraded to 2.7, i have noticed the images are not clickable. You can check out my site and see that in the first post image can be clicked (written in 2.6.4) but the second post image can't be clicked. Why so?

    Site - http://www.motorbeam.com/

  2. dressedinvalue
    Member
    Posted 5 years ago #

    The second image is not clickable because there is no <a> wrapped around it.

  3. BUSA
    Member
    Posted 5 years ago #

    Thanks for your answer. Before WP used to go that automatically. Now do i have to do it manually. I thought 2.7 would make things easier? Can you tell what exact changes do i need to make? Also I don't get option of putting a large image.

  4. SimonJ
    Member
    Posted 5 years ago #

    When you upload an image, or choose an image in your media library to put in your post, you have the field "link url" just below the description.

    From there, you have three buttons : "none" "file url" or "post url".

    If you do not enter a link manually, or click a button to fill this field, then, no link will be added, and the image will not be "clickable"

    S.

  5. dressedinvalue
    Member
    Posted 5 years ago #

    If I remember right, I think 2.7 changed this default behavior. It used to automatically link to the larger version of the image.

  6. SimonJ
    Member
    Posted 5 years ago #

    Yep... You are right...

    Even if you do not fill the field nor click a button, the "insert to post" will automaticaly imbed the image in a link to the attachment...

    So I take that back... The image should be clickable by default...

    then, BUSA, are you sure you didn't click the "none" button ? :-)

    S.

  7. BUSA
    Member
    Posted 5 years ago #

    Thanks SimonJ. Well when i upload a image, this is what shows default.

    http://fasbusa.googlepages.com/WP2.7AddingImage.JPG

    If you notice in the image, the large option is never there. However big the image is the large option is never clickable. I did not click any button so wondering why images are not clickable?

  8. tgiokdi
    Member
    Posted 5 years ago #

    i'm going to wager that the 'large' format is larger then the original image. try uploading something that's over 600 pixels wide and see if the option pops up then

  9. SimonJ
    Member
    Posted 5 years ago #

    Yes, I would guess that tgiokdi is right.

    I just made a short test and if the "medium" and "large" size defined in wp-admin => settings => media are larger than the original size of the picture uploded, these format are not generated by wordpress...

    By default, the large size in WordPress is 1024 x 1024 and the full size of your picture (the original size of the file itself), in the screen capture I see, is 536x290... This is why you don't have the "large" option...

    ---

    Now, why the link doesn't appear automatically in the ? ... Well, I don't know... On my side, if I choose an image in de media library or uplod a file from my computer the "file url" is always there by default...

    Hum...

    S.

  10. BUSA
    Member
    Posted 5 years ago #

    Thanks guys. Well not its fills the field automatically. However when ever i upload any sized image whether its more than 1024 x 768 or anything it never shows the large option, so everytime i have to manually go to html and replace the height and width. Before that was not the case. What could be the issue. Why doesn't it show me the large option ever?

  11. BUSA
    Member
    Posted 5 years ago #

  12. SimonJ
    Member
    Posted 5 years ago #

    Yeah, but this image in your example is 1024 wide...

    So it's not over the limit... :-)

    S.

  13. That example shows clickable buttons for small and medium, but not large (which is ... well, the 1024xfoo size) so it's working exactly as it should. If I look at your image directly, Firefox confirms it. You don't need the large option :)

  14. SimonJ
    Member
    Posted 5 years ago #

    Look on my side :

    My max width and max height are set to 1024 in my wordpress settings :

    With a 1024 x 768 :
    http://koolos.com/WP_DEV/share_img/1024_768.jpg
    The large option is not selectable, because the full size in under the limit.

    With a 2592 x 1944 image :
    http://koolos.com/WP_DEV/share_img/2592_1944.jpg
    The large option is selectable, because the full size in over the limit.

    S.

  15. Hah! SimonJ my office firewall blocks koolos! :)

  16. BUSA
    Member
    Posted 5 years ago #

    Thanks alot guys (Ipstenu and SimonJ). I guess this solves the problem.

    Special thanks to SimonJ for the help :)

  17. shaneholden
    Member
    Posted 5 years ago #

    Quick question about the Large Size image.

    Does the WP Gallery function still use just the thumbnail size and the medium?

    I'm trying to figure out when the Large would be used on my site, if ever at all. Maybe I should just make it larger than anything I'll be uploading and just ignore it for now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.