WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Image in my post works for IE but not Firefox (4 posts)

  1. cunparis
    Member
    Posted 7 years ago #

    I'm using this code to put an image at the beginning of my post:

    <img class="left" id="image12" src="/blog/wp-content/uploads/2006/10/astore-beta-logo-announceme.jpg" />

    It works for IE, but in Firefox the image is placed further down in my page. On the main page it's a problem because the image comes up in the middle of another article.

    I don't know if it's a Firefox bug or if I'm doing something wrong with my DIV tags. Any ideas?

    The page is:

    http://www.michaelmattox.com/blog/2006/10/04/amazons-omakase-astore-not-ready-for-primetime/

    And finally, is this really the best way to put images in my post? It seems like a special tag would be better, because if I ever switch from WordPress to another site my links aren't going to work.

  2. cunparis
    Member
    Posted 7 years ago #

    I forgot the relevant part of the stylesheet:

    img.left {
    float:left;
    border: 0px;
    margin: 5px 10px 0px 5px;
    }

  3. Evita
    Member
    Posted 7 years ago #

    Your image:

    <img src="http://www.assoc-amazon.com/e/ir?t=advanwebamazocom&l=ur2&o=1" width="1" height="1" border="0" alt="" style="border:none !important; margin:0px !important;" />

  4. cunparis
    Member
    Posted 7 years ago #

    I opened a bug with firefox, waiting to see what they say. either it's a bug firefox or it's just a loophole in the spec. The solution is to put all my divs on the right side in a containing div and float the containing div.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags