WordPress.org

Ready to get started?Download WordPress

Forums

Image have Disappeared from Themes! (10 posts)

  1. AvantReese
    Member
    Posted 6 years ago #

    All images have disappeared from my blog, the theme preview images don't even show on the dashboard. The images still show as being on the server.
    Note last night I had this problem: http://wordpress.org/support/topic/149591?replies=14&0 See my last reply there, I don't know if it's related. The images were not showing when I had Hotlink protection enabled (with my site allowed), but now they won't show whether it is enabled or not.

  2. AvantReese
    Member
    Posted 6 years ago #

    Correction, now after enabling and disabling the protection the images show again.
    How can I enable protection and still have the images show?

  3. whooami
    Member
    Posted 6 years ago #

    what site? the one in your profile? and what images, specifically, (give an example of one that is showing up that is NOT in the admin area).. we cant test that, we arent admins of your blog.

    I see images just fine on the site in your profile -- including a header image.

  4. whooami
    Member
    Posted 6 years ago #

    .. now that you have made a correction:

    blocking hotlinking means blocking hotlinking, including from yourself.

    If you want your domain to be able to hotlink, then add your domain to the list of domains that are allowed to hotlink. It does not get any easier than that.

    Fwiw, this is not a wordpress question :P

  5. AvantReese
    Member
    Posted 6 years ago #

    As I said, they are in the list. And I didn't know if the problem had anything to do with the hotlinking protection when I posted it (and therefore could have had something to do with WP), as it was not enabled.

  6. whooami
    Member
    Posted 6 years ago #

    wp doesnt have anything to do with hotlinking.

    this is an example of what you want in your .htaccess

    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^$ [NC]
    RewriteCond %{HTTP_REFERER} !ohbuoyancy\.net [NC]
    RewriteCond %{HTTP_REFERER} !google\. [NC]
    RewriteCond %{HTTP_REFERER} !bloglines\. [NC]
    RewriteCond %{HTTP_REFERER} !feedburner\. [NC]
    RewriteCond %{HTTP_REFERER} !live\.com [NC]
    RewriteCond %{HTTP_REFERER} !search\?q=cache [NC]
    RewriteRule \.(png|gif|jpe?g)$ - [NC,F]

  7. AvantReese
    Member
    Posted 6 years ago #

    I didn't say wordpress had anything to do with hotlinking! I didn't know if hotlinking was the problem, IT WAS NOT ENABLED!

  8. AvantReese
    Member
    Posted 6 years ago #

    This is my current problem:
    (I DO NOT HAVE HOTLINKING PROTECTION ENABLED)

    Images only show sporadically, if I go to my c-panel, enable hotlinking protection then disable it again immediately, images will work -until I do anything in the WP dashboard, then all pages quit working (About, post pages, etc, ALL pages), then I go to the WP settings for permalinks and save my settings again (without changing anything), then pages work but images quit showing again after a few minutes. It's an endless loop.

    Everything is working now, but for how long?

  9. whooami
    Member
    Posted 6 years ago #

    you said here:

    then I go to the WP settings for permalinks and save my settings again (without changing anything) ...

    If you would stop looking at things inside your cpanel, and look at the actual file (.htaccess) on your server you would see that it looks similar to what you pasted in your other thread:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    RewriteRule .* - [F]
    </IfModule>

    # END WordPress`

    IF, inside your .htaccess you are adding anything in between the begin and end statements, manually, its all going to be removed once you update your permalinks, whether you think you are making changes or not. You may not be making changes to your permalink structure, but you are making changes to that block of text.

    Additionally, from your other thread you will notice that the the tech guy at aso told you that your .htaccess was world-writable, and that he had "fixed" that. Notice also, that the permalink options page within wordpress clearly tells you that you must edit your .htaccess manually OR change the permissions on it in order for your changes to be made.

    In other words, wordpress is showing you in that box, what needs to be changed. YOU make the changes if wordpress cannot.And since your .htaccess isnt world-writable anymore, it cant.

    I have offered to help you -- you havent contacted me, so Im just going to say this...

    Ive explained this the best I can. I really recommend taking a deep breath and reading what you see eon the various administration pages that are provided to you by WordPress, as you do things.

    I have also shown you exactly how to disallow hotlinking while still allowing your site to load images.

  10. AvantReese
    Member
    Posted 6 years ago #


Topic Closed

This topic has been closed to new replies.

About this Topic