WordPress.org

Ready to get started?Download WordPress

Forums

Image Errors Wp-includes/media.php (6 posts)

  1. AltTab
    Member
    Posted 2 years ago #

    We are getting this error on one of our MU subdir sites with a particular template.

    Warning: imagecreatefromstring() [function.imagecreatefromstring]: Empty string or invalid image in /home/....../public_html/wp-includes/media.php on line 258
    Here is line 258
    $image = imagecreatefromstring( file_get_contents( $file ) );

    The template provider says its a wordpress file creating the issue. They indicated that the GD libaray was not functioning properly but the host TDM, indicated it was with a simple php file.

    We removed all 6-8 jpg images from the media folder on that subdirectory with no change.

    Any ideas or help would be greatly appreciated...

  2. Can you upload images in other sites?

    If so, what's different between THAT site and the others?

  3. AltTab
    Member
    Posted 2 years ago #

    We have checked the subdir sites that are using this particular theme and no matter if they have images or not, they produce this error.

  4. Using that theme. Well, the real answer there is 'That theme isn't working right, talk to the theme devs.'

    Does the theme use TimThumb?

  5. AltTab
    Member
    Posted 2 years ago #

    Yes on timthumb ...Here is what the host said:

    sounds like a permission issue..they also recently had a DDoS on the server....

    The module for the wordpress application you are mentioning in your latest reply is not familiar to us. Thus if the module has some requirements you should provide us with them so we can check if the module is compatible with the shared hosting environment on which your account is located.

    However since this is a module for the wordpress application we can assume that it is using the application requirements which are compatible with the environment.

    Regarding your inquiry for the mod_security this apache was enabled for the environment on which your account relies but we have disabled it.

    Thanks for your reply Ipstenu....

  6. It's not DDoS, most likely. It's the simple fact that TimThumb doesn't work WELL on Multisite, if at all.

    http://www.binarymoon.co.uk/2009/10/timthumb-wordpress-mu/

Topic Closed

This topic has been closed to new replies.

About this Topic