WordPress.org

Ready to get started?Download WordPress

Forums

Image editor broken in 2.9 (14 posts)

  1. jdalrymple
    Member
    Posted 4 years ago #

    I installed 2.9 last night and everything appears to work perfectly except the image editor. All of the images are still there, but when I click on one of them to edit it with the new editor, all I get is a broken image symbol.

    Any thoughts on what's causing this? I've tried it with several browsers on Windows and Mac with the same results.

    Thanks

    Jim

  2. phrz
    Member
    Posted 4 years ago #

    I have the same problem. After deactivating all my plugins it worked... So i'm now trying to activate my plugins 1 at the time and test it. Then i can find out which plugin causes this to happen. Keep you posted.

  3. jdalrymple
    Member
    Posted 4 years ago #

    Thanks, I'll wait to hear what you find out.

  4. phrz
    Member
    Posted 4 years ago #

    Sofar i've installed these plugins succesfully:
    Add Logo to Admin
    Avatars
    flickrRSS
    Shopp
    Sidebar Login
    Subscribe2
    Twitter Widget Pro
    Widget Logic
    WordPress Database Backup

    BUT
    After activating vipers video quicktags the image editor stopped working when clicking on an editor button (ie. flip horizontal ) ....
    After deactivating things work fine.

    This is what my firebug said:

    http://www.mywebsite.com/site/wp-admin/admin-ajax.php?action=imgedit-preview&_ajax_nonce=1773f184eb&postid=128&history=%5B%7B%22f%22%3A2%7D%5D&rand=309569
    
    Request headers
    
    Host: www.mywebsite.com
    User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
    Accept: image/png,image/*;q=0.8,*/*;q=0.5
    Accept-Language: nl,en-us;q=0.7,en;q=0.3
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    Referer: http://www.mywebsite.com/site/wp-admin/media.php?action=edit&attachment_id=128
    Cookie: wordpress_dead176dbc44556e7dae5ceb6f0dd8fc=admin%7C1261408863%7C4bb6a005843e164b0110fbe5d42308ad; wp-settings-1=m0%3Dc%26m1%3Do%26m2%3Dc%26m3%3Dc%26m4%3Dc%26m5%3Dc%26m6%3Dc%26m7%3Dc%26m8%3Dc%26m9%3Dc%26editor%3Dtinymce%26m10%3Do%26hidetb%3D1%26m11%3Dc; wp-settings-time-1=1261237139; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_dead176dbc44556e7dae5ceb6f0dd8fc=admin%7C1261408863%7Cc8c0087b94eb4a424b2d1a30840e5096; PHPSESSID=mrab0kc8u715hgk4s761vla074
    
    Response headers
    
    Date: Sat, 19 Dec 2009 15:41:51 GMT
    Server: Apache/2.2.0 (Fedora)
    X-Powered-By: PHP/5.2.11
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: wordpress_test_cookie=WP+Cookie+check; path=/site/
    Content-Length: 0
    Connection: close
    Content-Type: text/html; charset=UTF-8

    AND
    After activating wp-cufon the image editor stopped working when saving ....
    After deactivating it's still broken.

    I now get 500 Internal server errors All over the place:
    - admin-ajax.php
    - index-extra.php

    And the automatic re-install stopped working aswell.
    So i guess i'll re-install manually and restore the database..
    I've called with my hosting company support and they didn't have a solution for it...

    This is what my firebug said:

    http://www.mywebsite.com/site/wp-admin/admin-ajax.php
    
    Request headers
    
    Host: www.mywebsite.com
    User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
    Accept: */*
    Accept-Language: nl,en-us;q=0.7,en;q=0.3
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    Content-Type: application/x-www-form-urlencoded; charset=UTF-8
    X-Requested-With: XMLHttpRequest
    Referer: http://www.mywebsite.com/site/wp-admin/media.php?action=edit&attachment_id=128
    Content-Length: 106
    Cookie: wordpress_dead176dbc44556e7dae5ceb6f0dd8fc=admin%7C1261408863%7C4bb6a005843e164b0110fbe5d42308ad; wp-settings-1=m0%3Dc%26m1%3Do%26m2%3Dc%26m3%3Dc%26m4%3Dc%26m5%3Dc%26m6%3Dc%26m7%3Dc%26m8%3Dc%26m9%3Dc%26editor%3Dtinymce%26m10%3Do%26hidetb%3D1%26m11%3Dc; wp-settings-time-1=1261237139; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_dead176dbc44556e7dae5ceb6f0dd8fc=admin%7C1261408863%7Cc8c0087b94eb4a424b2d1a30840e5096; PHPSESSID=mrab0kc8u715hgk4s761vla074
    Pragma: no-cache
    Cache-Control: no-cache
    
    Response headers
    
    Date: Sat, 19 Dec 2009 15:49:05 GMT
    Server: Apache/2.2.0 (Fedora)
    X-Powered-By: PHP/5.2.11
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: wordpress_test_cookie=WP+Cookie+check; path=/site/
    Content-Length: 0
    Connection: close
    Content-Type: text/html; charset=UTF-8

    So WP-CUFON and VIPERS VIDEO QUICKTAGS aren't that compatible :)
    I'll try re-installing now...

  5. jdalrymple
    Member
    Posted 4 years ago #

    Holy Crap!

    Well, I'm not using either of those plug-ins, so I guess I'll see if I can find the culprit.

  6. jdalrymple
    Member
    Posted 4 years ago #

    Okay, found it. Mine was the Degaa plug-in. It works perfectly after disabling that. I just put the tracking code in the footer and everything is fine.

  7. phrz
    Member
    Posted 4 years ago #

    Hehe ...

    Well i just re-installed and the 500 internal server errors where still there. So i decided to deactivate some plugins and when i deactivated the subscribe 2 plugin the errors in index-extra.php a and admin-ajax.php where gone.

    It seems like plugins that use the ajax libraries conflict with the wordpress core functionallity... i'm not sure why.

  8. betadog
    Member
    Posted 4 years ago #

    Same problem here. I see the broken image symbol in the image editor. Crop, Redo and Undo are greyed out. The rotate and flip buttons are clickable but do nothing (except display a loading icon).

    I have disabled ALL my plugins - no changes.

    I've managed to get the new image editor to work on a different server though. So what exactly are the server requirements again?

  9. jasonayre
    Member
    Posted 4 years ago #

    Yep, I am having the problem also. Running it on two different servers, one it works perfectly, one it does not. - I see No edit button and I cant crop, or even select anything but the largest size when uploading. -- Ive noticed that my permissions on one of the servers are 777 and the other 767, if that is the case, wouldnt that be considered a bug considering in the wordpress documentation it specifically says not to set your permissions to 777?

  10. betadog
    Member
    Posted 4 years ago #

    @jasonayre What permissions? Those of the uploaded media files?

    @jasonayre Does it work on the other server if you change the permissions?

  11. JenniferNM
    Member
    Posted 4 years ago #

    Not as technically proficient as some of the other posters on this thread, but I cannot upload any images to WordPress AT ALL, much less insert one into a post. When I use the image uploader (have tried the flash uploader too), no image is displayed in the media list. Going to the link where the image is stored simply shows me the title and nothing else.

    I'm going through the plug-ins one by one and deactivating them to see if this resolves the problem. No luck so far.

    Any advice or suggestions appreciated.

  12. dsortax
    Member
    Posted 4 years ago #

    Images problems here too. Fix that wp!

  13. dell80
    Member
    Posted 4 years ago #

    Was having this problem to finnaly figured out what was causing the issue for me was blank lines inbetween php stanzas, what I had to do was delete all blank lines between php script tags or just combine the blocks of code.

  14. mothmenace
    Member
    Posted 4 years ago #

    If the image editor is showing no image, check your WP upload path is correct.

Topic Closed

This topic has been closed to new replies.

About this Topic