WordPress.org

Ready to get started?Download WordPress

Forums

Image doesn't upload in WP2.02 (11 posts)

  1. adventure4th
    Member
    Posted 8 years ago #

    When I try to upload an image in a post or page I get the following message - 'The uploaded file could not be moved to .'

    I have permissions set to 777 on all folders on the path. I can upload the images to the wp-content/uploads folder by ftp but not through wp. Have turned off the popup blocker to no effect. The code for the default folder in the options-misc.php folder is:-

    <input name="upload_path" type="text" id="upload_path" class="code" value="<?php echo str_replace(ABSPATH, '', get_settings('upload_path')); ?>" size="40" />

    Is this ok? Is anything missing here? Could the popup blocker or firewall be affecting it? Can anyone help please?

    Have tried to fix this for hours - side benefit is I've learnt alot about wp, php and plugins in the process.

  2. Aleister
    Member
    Posted 8 years ago #

    I would delete and re-create the uploads folder.. then set the permissions again..

    When you installed WordPress, it might have created the directory as another user. Worth a shot anyway :)

  3. adventure4th
    Member
    Posted 8 years ago #

    Thanks for the reply. Unfortunately that didn't work. I deleted the uploads folder. WP creates a new uploads folder when the first upload is done. It did that but isn't able to upload the image to it. I rechecked the permissions on all the folders on the path and they are all 777 including the new uploads folder created by wp. I can upload images to that folder by ftp so I assume the problem has something to do with how the image popup works when the image is uploaded. I saw a tutorial that showed how it is supposed to work but that's not happening for me.

  4. twotwentysix
    Member
    Posted 8 years ago #

    I have had this problem for so long now, if you find out how to fix it please let me know.
    I have opened several threads but no one replies.
    I would much appreciate it if you could tell me when you fix it.
    thanks!

  5. Aleister
    Member
    Posted 8 years ago #

    Do not let WP create the folder, delete it and manually create it yourself then set the permissions.

    If WP is creating it, that could be why the permissions are not there, since WP is not creating it with your user account credentials.

  6. adventure4th
    Member
    Posted 8 years ago #

    It worked! Brilliant!! Thank you very much Aleister

  7. adventure4th
    Member
    Posted 8 years ago #

    PS to member twotwentysix. I hope you check back here for the good news because I can't see how to contact you directly.

  8. Aleister
    Member
    Posted 8 years ago #

    Glad to hear it! :)

  9. kickass
    Member
    Posted 8 years ago #

    I use the Image Manager Plugin for my clients. They seem to like that it's really easy, intuitive and the setup is clear and concise. You can also turn off the WP default upload and just use the IM upload, which is nice and works wonderfully. Plugin here:
    http://soderlind.no/

  10. adventure4th
    Member
    Posted 8 years ago #

    Whoops seems I was a bit quick off the mark. Images upload and are in the folder but only the file name and link is shown in the text. When I view the post no image shows just the image name.

    Will try kickass's suggestion. Thanks for all the feedback.

  11. twotwentysix
    Member
    Posted 8 years ago #

    hey, I am still here :-)
    I am also trying http://soderlind.no/ image manager but there is also a problem there because it doesnt work on my mac, but the site admin is checking the bug out.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.