WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate Posts Widget
image displayed as broken link after jetpack 2.1.2 update (13 posts)

  1. profun
    Member
    Posted 1 year ago #

    Hi,
    After the update to jetpack 2.1.2, the widget displays a broken link instead of thumbnail image (images are JPEG). I have checked the media gallery and all images are OK.
    http://lumeaparalela.ro/
    Before the update, everything was OK.
    I really like your plugin and I would not like to deactivate it.

    thanks!

    http://wordpress.org/extend/plugins/ultimate-posts-widget/

  2. rescuedigest
    Member
    Posted 1 year ago #

    I too have found this issue at http://www.RescueDigest.com

    I've currently disabled it and the issue resolved immediately.

  3. bostondv
    Member
    Plugin Author

    Posted 1 year ago #

    This issue seems to be caused by the "Photon" component of Jetpack. Timthumb, which is used to generate the thumbnails is not compatible.

    Try disabling Photon and it should start working again.

  4. geoffreysf
    Member
    Posted 1 year ago #

    Weirdly, my timthumb (and thus the widget) is working fine on Firefox, but does not work on any other browser.

  5. geoffreysf
    Member
    Posted 1 year ago #

    Just an FYI: I also updated the timthumb.php file to the latest, 2.8.11 and that didn't help either.

  6. mandirao
    Member
    Posted 1 year ago #

    I'm having the exact same problem. I am running Jetpack, but I do not have Photon enabled. Any other suggestions??

    EDIT: It may not be the EXACT same, but it's hard to say. When I clear my cache the photos show up. But if I come back to the site the next day the images again display as broken links. I can't very well have our users refresh their cache on each visit! :-)

    My site is at: http://www.faultlinetheatre.org/ . The 2nd and 4th box are the UPWs in question.

    I've tested on Chrome, Firefox and Safari, on my Mac, iPad and Android all with the same results. I'm running WordPress 3.5.1.

    I otherwise love this plugin! I really don't want to have to look elsewhere.

  7. analyticcreative
    Member
    Posted 1 year ago #

    I also have the same problem - using UltimatePosts on the front page and thumbnail just shows broken link. Where do I disable photon/Timthumb?? Is there another fix for this yet?

  8. analyticcreative
    Member
    Posted 1 year ago #

    I am not running Jetpack and I still have issues using this widget. Can't seem to find a reason. Looks like I will have to deactivate the plug in until I can resolve it. I need to have a thumbnail on the random post.

  9. bostondv
    Member
    Plugin Author

    Posted 1 year ago #

    I'll do some testing this weekend to try and find the issue. For now, try these troubleshooting tips:

    - Jetpack "Photon" feature conflicts with timthumb, make sure it's disabled.

    - Timthumb has various requirements such as PHP-GD on the server as well as write permissions (777) to the "/cache/" directory. Check out this troubleshooting info: http://www.binarymoon.co.uk/2010/11/timthumb-hints-tips/

  10. leancab
    Member
    Posted 1 year ago #

    seems like the image source have a problem. Look those parameters at the end http://....../wp-content/plugins/ultima…2013/wordpress2/wp-content/uploads/2013/04/pic1.jpg&h=100&w=100&zc=1

    it is breaking the path

  11. justinheron
    Member
    Posted 1 year ago #

    I have the same issue and dont have Jet Pack installed in this instance.

  12. bostondv
    Member
    Plugin Author

    Posted 1 year ago #

    I've just posted a new version 1.5.1 which may help fix the issues. Please try updating and review the new FAQ.

    If you continue to experience issues after updating and going through all troubleshooting steps in the FAQ please comment with the following information:

    - Error message displayed when "right clicking > view image" on the image
    - Link to the page where image is not displaying
    - Version of PHP
    - Version of WordPress

    Thank you

  13. bostondv
    Member
    Plugin Author

    Posted 1 year ago #

    Additional tip for troubleshooting. If you have a tilde (~) in your url you'll need to use an alternate url due to a known timthumb bug: https://code.google.com/p/timthumb/issues/detail?id=263

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic