WordPress.org

Ready to get started?Download WordPress

Forums

Image Cannot Be Loaded (5 posts)

  1. zenner1103
    Member
    Posted 1 year ago #

    I just added photos to my portfolio galleries, and when you click on the image a box pops up that says,

    "Image cannot be loaded. Make sure the path is correct and image exists."

    I have seen others have this problem but I have not been able to fix it myself. Is there a plugin I need to install? Is it prettyphoto? Why is this happening and what can I do?

    My website is:

    http://www.jenna-miller-photography.com

  2. mli1102
    Member
    Posted 1 year ago #

    Hi,

    I just did a quick test on my installation – it seems that there is a bug with the default WordPress gallery inserting – when you insert a gallery for the first time, it doesn’t insert the link="file" in the shortcode (they made lots of changes in WP 3.5). So, in this case there are two solutions:
    - It seems that it works when you follow these steps:
    1. Insert the gallery
    2. Click on edit and select "Attachment page" in the link option and update the settings
    3. Click again on edit and select "Media File" and update the settings
    after you follow these steps, it updates the shortcode attributes.

    Regards
    Martin

  3. duerro
    Member
    Posted 1 year ago #

    Yeah, experienced the same problem. mli1102's Workaround did the job. Sadly one has to do that on every gallery by hand.

    Hope theres gonna be an update soon to fix the problem.

    thnx @ mli1102

  4. JamesMcWhorter
    Member
    Posted 10 months ago #

    Thank you for the tip, mli1102. This resolved the issue that I was having.

    However, this is the first time I've run into this issue.

    I looked at the short code that is generated on my personal site and link="file" never shows up in the short code.

    Here is the short code for http://jamesmcwhorter.com/2013/05/trinidad-head-california/

    [gallery ids="2162,2163,2164,2165,2166,2167,2168,2169,2170,2171,2172,2173,
    2174,2175,2176,2177,2178,2179,2180,2181,2182,2183,2184,2185,2191,
    2192"]

    Perhaps this has something to do with JetPack's Carousel feature?

  5. cs@it911.ca
    Member
    Posted 7 months ago #

    I ran into the same issue... I discovered that when the picture URL was put into the browser I received an HTTP error and it could not obtain the picture path..

    For me it turned out to be an IIS permission issue. When WP was setup the default permissions did not include the IUSR permission at the root of the site folder ie: C:\inetpub\wwwroot\Cottageonthewater

    Now when I invetigated the permissions assigned to the uploads folder I found the IUSR permissions configured

    ie: C:\inetpub\wwwroot\Cottageonthewater\wp-content\uploads

    I therefore added the READ permission for the User 'IUSR' to the root folder:
    C:\inetpub\wwwroot\Cottageonthewater

    This resovled the issue. The issue here is that the IUSR user is used for the visitor to review/read content and that User did not have rights to access the resource.

    Hope this assists someone.

    CHeers

Topic Closed

This topic has been closed to new replies.

About this Topic