WordPress.org

Ready to get started?Download WordPress

Forums

Spun
[resolved] Image attachment aligned to center of page instead of left-side (8 posts)

  1. Wietsss
    Member
    Posted 5 months ago #

    Hello, I absolutely love the Spun theme, but I have a little question about the aligment of the attachments in for example this post: http://wietske-dejong.nl/?attachment_id=107#main

    I'd like to center the image, but I don't know how to. Also I added the images into the posts as a gallery, but when I viewed the post, there were circles with my images and below the circles there were the images again, but then inside the post. So I removed the images from the post (in my dashboard-posts menu.) So the circles are showing the right images, but I can't find them in the code.

    I hope someone can help me. Thank you in advance!

  2. ShaiRoelud
    Member
    Posted 5 months ago #

    Hi Wietske,

    I think this should work:

    If you go to your post in the Edit-mode and click on your image, two icons should appear. Click on the left one that looks like a landscape. A new window should open. Set Alignment to center and click update. Next, click on the update button for your post and you should be set.

    Cheers,
    Roel

  3. Wietsss
    Member
    Posted 5 months ago #

    Wouw, that was fast! Thank you very much. The problem is that that are no images in the edit-mode, but for some reason they still show up in the circles inside the posts. But I can't click them and if I put the images inside the post in edit-mode they will show up in squares, underneath the circles. It's a bit hard to explain, but I hope I'm clear enugh!

  4. Wietsss
    Member
    Posted 5 months ago #

    O! I figured out that when I deselect 'gallery' in edit-mode in the post, the circles disappear, so I guess I have to change the 'gallery' settings to get my center alignment?

  5. ShaiRoelud
    Member
    Posted 5 months ago #

    I don't use galleries on my website so unfortunately I'm not too familiar with those. However, when I look at the code of your site when I look at an image that is in the gallery, I think this might work:

    .entry-content img, img.size-full {
        display: block;
        margin-left: auto;
        margin-right: auto;
        max-width: 100%;
    }

    I don't know if you've set up a child theme, but if you did, try and copy-paste this into you child theme's style.css and let me know if it worked.

    Cheers,
    Roel

  6. Wietsss
    Member
    Posted 5 months ago #

    Thank you so much! I wish I could send you flowers, but I think the flowers will be long dead when they arrive, because I live in the Netherlands, but still! Have a nice day :)

  7. ShaiRoelud
    Member
    Posted 5 months ago #

    I'm Dutch as well, but live in the US now so I'm pretty sure you're right about the flowers. If I ever move back to Utrecht, I'll let you know ;)

    Maar mooi dat het werkt, succes ermee.

    Cheers,
    Roel

  8. Wietsss
    Member
    Posted 5 months ago #

    Haha, nou hierbij de groetjes uit Utrecht! (of nouja, Zeist eigenlijk) And again, thanks for your help :)

Reply

You must log in to post.

About this Theme

About this Topic