WordPress.org

Ready to get started?Download WordPress

Forums

I'm unable to drag widgets to the sidebar... (15 posts)

  1. alitomr
    Member
    Posted 3 years ago #

    or add sidebars.

    I checked the forums for possible answers and the most recommended procedure was to network disable all plugins.

    BTW, in the widgets pages, the screen options or help, located in the top right of the page, dont respond when clicked on.

    I am running a network but there is only ONE active blog on it. I dont know if this helps but all blogs in the network are subdomains.

    I do have widgetized themes.

    I have spent several hours trying to fix this. Your help will be extremely appreciated.

  2. MrJPH
    Member
    Posted 3 years ago #

    While you are in your wp-admin page, in your sidebar along the left side of the page, go down to 'Appearance' > 'Widgets', on the Widgets page, in either the 'Available Widgets' section at the top of the page, or, in the 'Inactive Widgets' section at the bottom of the page, by clicking on either the 'Add' (Available Widgets), or the 'Edit' (Inactive Widgets), both are on the right hand side of each widget.

    When you do that, you are taken to the edit page of that widget, and from there, you can choose the Widget Area that you want to place it in, and it's position (if you have more than one already in that Area).

    What, and where, your particular theme's Primary, Secondary, etc., Widget Areas are located within it, you'll have to find out for yourself, and the layout you have chosen within that theme, i.e., 'sidebar-content', or 'sidebar-content-sidebar', etc.

  3. alitomr
    Member
    Posted 3 years ago #

    The edit or ADD buttons on the right of active or inactive widgets are not available.

  4. MrJPH
    Member
    Posted 3 years ago #

    I don't know if this will do it or not (I am a newbie) but, in the top right hand corner, it has a tab saying 'Screen Options', when you click on that, it drops down, and has, I am guessing has - 'Enable accessibility mode', click on that, and see if the ability to 'Add' and 'Edit' appears for you.

    When I click on that 'Screen Options' tab, it says 'Disable accessibility mode' for me, my thinking because I can see 'Add' & 'Edit' abilities with each widget... so, that is why I am guessing, and hoping, that it will say "Enable accessibility mode" for you, and perhaps will give you then the option to then 'Add' & 'Edit'.

    I hope it works.

  5. alitomr
    Member
    Posted 3 years ago #

    Thank you for your contribution,JP, but I specifically said that when the Screen Options are clicked, nothing happens:

    BTW, in the widgets pages, the screen options or help, located in the top right of the page, dont respond when clicked on.

    I even downloaded and installed the latest Java to see if it solved the problem but nothing seems to work.

    I have already tried with different browsers, specifically with the Mozilla 4.0, Explorer 9 and the latest Chrome. Nothing works.

    As I said, I've spent so many hours trying to fix this it's absurd.

  6. MrJPH
    Member
    Posted 3 years ago #

    I'm sorry, alitomr, I obviously completely missed you saying that even those options, for some reason do not work for you.

    I'm sorry I'm not much help then, as I am at a loss also as to why those wouldn't be working for you.

    I would suggest maybe checking the browsers preferences, perhaps maybe you need to check them to enable JavaScript, and/or Java... maybe that's what makes those things work.

  7. alitomr
    Member
    Posted 3 years ago #

    Thank you for your time, man!! I really appreciate it.

    Let's hope somebody else knows the answer.

    :)

  8. alitomr
    Member
    Posted 3 years ago #

    I think it's worth mentioning that I havent been able to use the widgets in a long time. I even thought my theme didnt support it and it wasnt until last night when I noticed it does support them.

    I uploaded a new widgets.pho to my /wp-admin folder and I still cant get the "screen options" or "help" to do anything in the widgets.php file.

  9. alitomr
    Member
    Posted 3 years ago #

    I'm using the latest available stable version of wordpress, 3.1.2.

  10. alitomr
    Member
    Posted 3 years ago #

    Anybody? Please!!

    I cannot use widgets and I feel crippled!!!

  11. govpatel
    Member
    Posted 3 years ago #

    May be one of plugin is conflicting try and deactivate plugins and see that solves your problem.

  12. hyochangkim
    Member
    Posted 3 years ago #

    MrJPH, thank you very much. In the process of upgrading my genesis/lifestyle theme on one of my sites, I got the white screen of death. After spending a good part of my afternoon of ripping my hair out, I finally got my website up, only to find the widgets not responding. After more hair pulling, I stumbled on this forum and your advice to hit the enable accessibility mode did the trick. again, thanks
    hyo

  13. alitomr
    Member
    Posted 3 years ago #

    govpatel,

    I already tried that and it doesnt work. I removed them via the gui and also manually from cpanel (some of them were giving a 404 error -file not found-). I tried clicking on the "screen options" and it didnt work, even with no plugins installed in the wordpress network.

    This is beyond frustrating now :(

  14. govpatel
    Member
    Posted 3 years ago #

    @alitomr switch to default twenty ten theme see if still have problem

  15. Yael K. Miller
    Member
    Posted 3 years ago #

    @MrJPH Thanks so much! I had the same problem with the widgets not dragging and it turns out that accessibility mode was enabled. I didn't even know such a thing existed.

Topic Closed

This topic has been closed to new replies.

About this Topic