WordPress.org

Ready to get started?Download WordPress

Forums

I'm trying to install wordpress on localhost (using XAMPP) (11 posts)

  1. SandySynaptik
    Member
    Posted 3 years ago #

    I have just now downloaded WordPress 3.1, extracted it and copied 'wordpress' folder to "htdocs" folder of XAMPP. Now whenever I go to http://localhost/wordpress/ and try to Setup the Configuration File and Click on submit; this error comes:
    Error establishing a database connection and also there was a link to the WordPress support forum from which I am directed to here, please tell me what to do.

  2. abhilol
    Member
    Posted 3 years ago #

    Did you create a database and user for WordPress?

  3. SandySynaptik
    Member
    Posted 3 years ago #

    How do I create one? Sorry for bothering but I'm new to PHP & MySQL and still learning them.

  4. dmartu
    Member
    Posted 3 years ago #

    asdasd

  5. arkgroup
    Member
    Posted 3 years ago #

    dmartu,

    Very helpful! You rock.

    SandySynaptik

    Access phpMyAdmin, you'll be able to create database there. Then you'll need to type database name you create, username and password from phpMyAdmin as database username and password. Database server should remain localhost.

  6. SandySynaptik
    Member
    Posted 3 years ago #

    Thanks arkgroup,
    Everything has gone right, but the when I click on install, this page comes:
    http://localhost/wordpress/wp-admin/install.php
    which is totally blank. What to do next?

  7. arkgroup
    Member
    Posted 3 years ago #

    SandySynaptik,

    Edit php.ini file. Look for such line:

    display_errors Off

    Change this line to:

    display_errors On

    And then access that link again. You'll see exact error. You may post it here.

  8. SandySynaptik
    Member
    Posted 3 years ago #

    or I say http://localhost/wordpress/ is not opening as well.

    [I have just created a database, not any table] if I was suppose to make table, please instruct me]

  9. SandySynaptik
    Member
    Posted 3 years ago #

    @arkgroup
    They are already set to be on but still a blank page is coming instead of error

  10. datasoftict
    Member
    Posted 3 years ago #

    Open yor wp-config.php file in the wordpress root folder and set the WP_DEBUG to 'true', just change the false to true and save. (Remeber to change this back again when you have the site working!)

    Go back and run the install again, log into the localhost/wordpress site, don't go into install.php. The WP_DEBUG option will show any error messages from PHP on the screen. See if any come up when you try the installation.

    I always double check through the windows administration > services interface that both apache and mysql are actually running.

  11. HafidMF
    Member
    Posted 3 years ago #

    Maybe you need read this one to, I've reply one question *I think it same problem with xampp* in there.

    Don't worry I'm newbie too... actualy I'm using AppServ but I know a bit about xampp installation, after instal xampp [i asume you've read the reply at that link] you need create database, just click on the xampp control panel, beside mysql button [Admin button] it directly run phpmyadmin, and you add database there. Maybe this link can help you too.

Topic Closed

This topic has been closed to new replies.

About this Topic