WordPress.org

Ready to get started?Download WordPress

Forums

I'm not really sure where I went wrong, but it went REALLY wrong. (10 posts)

  1. imanster
    Member
    Posted 7 years ago #

    I'm really, basically, about to tear my hair out.
    I've installed wordpress, and can blog, and everything's fine at
    iman.freehostia.com/WordPress

    But, the thing is, my layout is at
    iman.freehostia.com
    And I want my worpress blog to appear inside the space I've provided for it! I've tried includes from sites I've found, and to no avail.

    I can't seem to figure out how to finally put it. Can someone please help?
    I'm new to this, so please tell me whether I need to include coding and how. :(

  2. imanster
    Member
    Posted 7 years ago #

    Great. And now I realize that I've stuck this thread in the wrong forum.
    Pfffft. This really isn't my day.

  3. rudolf45
    Member
    Posted 7 years ago #

    Try to search for "integrate" and similar keywords. Probably, a closer look at the Loop will help: basically, that's what you need to have on your main page.

  4. imanster
    Member
    Posted 7 years ago #

    It's probably something with The Loop, like you said...but here's an error statement I just got.

    "Fatal error: Call to undefined function: get_header() in /home/www/iman.freehostia.com/index.php on line 13"

    Does someone know what that could mean?

  5. peiqinglong
    Member
    Posted 7 years ago #

    /home/www/iman.freehostia.com/index.php

    This is wrong. This line, iman.freehostia.com should not be in that sentence. It should be absolute path, so something like: /home/www/iman/index.php.

    Here's how to find absolute path: http://www.bui4ever.com/web-itecture/how_to_integrate_wordpress_and_bbpress/quote-comment-619/

  6. imanster
    Member
    Posted 7 years ago #

    :) Thank youuu! I removed it and it's in there now. FINALLY.
    I only have a few more problems...
    It's not following my stylesheet, only the links are...
    And whenever I click on a link, it takes me to the original wordpress blog. Is there any way I can get rid of that and make it stay in the current layout?
    Or do I have to...build my site around it?

  7. rudolf45
    Member
    Posted 7 years ago #

    That's the big problem with using the Loop in a different layout: any internal WP link will take you back to the blog. If you want to avoid it, you have 2 options:
    - create a theme that looks like your main site
    - eliminate the internal links

  8. peiqinglong
    Member
    Posted 7 years ago #

    The best option is to create a theme that is like your website. You'll probably pull out your hair doing it, but making future changes will be so much easier later and also expandability. It is worth it.

  9. imanster
    Member
    Posted 7 years ago #

    Hmm...I went to the option page and changed the page that my blog will appear on to my site's URL. It gave me the results I wanted.
    :D But NOW my problem is that when someone tries to comment, the comment box kind of overflows out of the DIV, I want to know how and where I can resize it?
    And the other problem is in my stylesheet, I've put in values for bold, italic, and linked text, but in my blog, the only text that follows the CSS is are the links. Is there a way to make the bold and italics also follow the CSS?

  10. peiqinglong
    Member
    Posted 7 years ago #

    You need to style the comment box, its in the stylesheet and if not, just do textarea {width: 80%; overflow: hidden; } or something to that affect.

    What do you mean you put the values for bold and italic in linked text? Are you using the correct CSS codes?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags