WordPress.org

Ready to get started?Download WordPress

Forums

I'm having problems with a theme I made. Can anyone help me? Thanks (5 posts)

  1. graciedesign
    Member
    Posted 2 years ago #

    Hello, I just made a theme for my website and so far I got this error message:

    http://www.graciedesign.net

    And I'm trying to make it look like this, which I made a mockup out of.

    https://lh3.googleusercontent.com/-ipbaAZcm5ZM/Ttwyn03bAiI/AAAAAAAAAGU/bJvl-crUGeA/s512/Layout.png

    I know I created some templates for it but is there anything I'm doing wrong? Can anyone help me on how to fix this so that way I can make my site look better? Thanks.

  2. premiumwp
    Member
    Posted 2 years ago #

    All that is saying is line 23 of your index.php file has a “:” where there shouldn’t be.

    You will need post the code or at least line 23 of "index.php" for people to help you identify how to fix the problem

  3. graciedesign
    Member
    Posted 2 years ago #

    This is the code I made for line 22-25 with index.php in Dreamweaver:

    https://lh5.googleusercontent.com/-Fln_zyVMqZQ/TtzfaqTyGgI/AAAAAAAAAGg/UTENrIXucKo/s577/line%25252022-25.png

    However it looks like I had a typo error below line 23.

  4. graciedesign
    Member
    Posted 2 years ago #

    Sorry to post here again but here's the code for my index.php.

    <?php get_header(); ?>
    <div id="main">
    <div id="container">
    <div id="content">

    <?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>
    <div <?php post_class(); ?>>
    <h2>"><?php the_title(); ?></h2>
    <?php the_content(); ?>

    <div class="postInfo">

      <li class="date">Date Posted:<?php the_time('F jS Y'); ?>
      <li class="category">Where:<?php the_category(','); ?>

    </div>
    </div>

    <?php endwhile; ?>

    <div class="pagination">
    <p class="prev"><?php next_posts_link('<Previous'): ?></p>
    <p class="next"><?php previoust_posts_link('Next>'): ?></p>
    </div>

    <?php else : ?>

    <div class="nothing">
    <h1>Nothing Found</h1>
    <p>Sorry, but the page you are looking for isnt here.</p>
    <p>">Return to homepage</p>
    </div>

    <?php endif; ?>

    </div><!--#content-->

    <?php get_sidebar(): ?>

    </div><!--#container-->

    <?php get_footer(); ?>

    </div><!--#main-->

    Are there any changes that I need to make in order for it to run better?

  5. premiumwp
    Member
    Posted 2 years ago #

    For a start you need to use ";" instead of ":" on line 23 and 24.

    Looks like there a few other places also

Topic Closed

This topic has been closed to new replies.

About this Topic