WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Simple Firewall
[resolved] I'm a human button/text issue (9 posts)

  1. geocliptic
    Member
    Posted 1 month ago #

    I installed WordPress Simple Firewall, created the settings and was fat and happy. I really didn't know what to look for. I recently cloned my site to a localhost machine and went to the login screen and saw a "I'm a human" text/button there. Great. But, it wasn't/isn't on my live site. I absolutely cloned my live site and know not where to look for the problem. I double checked the WPSF settings and still can't figure out the difference. My localhost page source has <style> and <script> tags that do not show up on my live site. I've probably missed something, but the two sites *appear* to be identical.

    Thank you
    http://www.geocliptic.com

    https://wordpress.org/plugins/wp-simple-firewall/

  2. Paul G.
    Member
    Plugin Author

    Posted 1 month ago #

    Hi,

    I'm not sure I fully understand the issue here.

    Are you saying that the live site isn't showing the checkbox, but when you cloned it to your localhost, it is?

    The problem could be Javascript - if this isn't enabled on a specific site, for example, the checkbox wont show up.

    Could that be it?

  3. geocliptic
    Member
    Posted 1 month ago #

    Paul,

    Thanks for the quick reply. That is exactly my issue.

    I am nowhere near being a Javascript expert, I do have it enabled in Safari, which I use for remote and local(host) tasks. Is that what you mean, or are there other things to set/do? Is there a server side switch to flip?

    Regards

  4. Paul G.
    Member
    Plugin Author

    Posted 1 month ago #

    Is the site you're referring to: http://www.geocliptic.com

    because the login form shows the checkbox for me... which site is it?

    Thanks,
    Paul.

  5. geocliptic
    Member
    Posted 1 month ago #

    Paul
    Yep, that's it. So I guess it's not a Javascript issue. As I would have guessed, it's me and not you. My Chrome doesn't show it either. Any help would be appreciated.

    Thank you,
    Ron

  6. geocliptic
    Member
    Posted 1 month ago #

    This appears to not be a WordPress Simple Firewall issue, so I will mark this topic as resolved. But, again, if someone wants to guide me in the right direction, it would be appreciated.

    Thank You
    Ron

  7. Paul G.
    Member
    Plugin Author

    Posted 1 month ago #

    Hey Ron,

    Best bet here is to disable a plugin, one at a time until you find the culprit.

    80% of the world's problems relating to WordPress are plugins. :)

    There could be an issue relating to the firewall also, so keep me posted.

  8. geocliptic
    Member
    Posted 1 month ago #

    Paul,

    Good suggestion on the plugins, but no joy.

    But I did find the problem. I turned off WIFI on my iPad and iPhone and I get the button. So my IP address is causing this. I deleted my IP address on both of your whitelist locations (firewall & login protect) and I get the button. The reason my localhost is exempt is that it says my IP address is: "Your IP address is: ::1"

    So perhaps this is how you intended it to work. Kinda makes sense. If I'm on the whitelist why bother me with a button. I guess everybody but me knows this, so nobody but me is complaining. My face is red.

    Anyway, I am very happy and very appreciative that you would take the time to help.

    Kindest regards,
    Ron

  9. Paul G.
    Member
    Plugin Author

    Posted 1 month ago #

    Ahh... you'd added yourself to the white list so you wouldn't have login checking. I don't know why I didn't think of that! My face is red :P

    Glad you got it sorted.

    Can I ask ya to leave us a wee review if you like the plugin? Helps with its profile and uptake. Cheers!
    Paul.

Reply

You must log in to post.

About this Plugin

About this Topic