WordPress.org

Ready to get started?Download WordPress

Forums

IIS7.5 localhost auto update problems (cannot find wp-content) (9 posts)

  1. richardpd
    Member
    Posted 1 year ago #

    I have used a localhostserver test environment on my Windows computer for a long time now. I have used several Windows WordPress install methods eg WebMatrix / WebPlatformInstaller WordPress installs and also a manual install with IIS7.5 via inetpub>wwwroot>wordpress directories.

    With this last approach I have never been able to update WordPress automatically as I had not enabled Windows FTP Server. I have always updated this localhost WP manually. Well with the recent latest version of WP (3.4.2) I have enabled FTP server in an attempt to enable auto update. Then on trying auto update at first I had a problem with FTP and WP error message saying " cannot connect-server error".

    I think this was due to incorrect FTP details and I have fixed that but now I have an error message "install failed-cannot find wp-content directory". I am now trying to fix this & would appreciate help to do so.What is the cause of this? A permission error? I have googled for help with this but as yet not found a fix.

    So I look forward to helpful replies to help me fix this-thanks

  2. WPProHelp
    Member
    Posted 1 year ago #

    What is the configured home directory for the FTP user? It should be the root of the WordPress installation.

  3. richardpd
    Member
    Posted 1 year ago #

    Hi
    Thanks for your reply.

    The WP is installed in
    inetpub>wwwroot>wordpress3

    wordpress3 directory contains wp-content / wp-admin etc and presumably is the root directory and afaik is ftp enabled but I will double check....
    (I am about to go out to work for the afternoon & will have to look at it this evening)

  4. richardpd
    Member
    Posted 1 year ago #

    I still haven't fixed this.
    Tonight I have tried all sorts of different ideas (allocating ftp user name as the user account eg IUSR & setting ftp password & permissions-anonymous and basic authentication too)with no success.
    I'm still not sure that the WP site folder is the root of the ftp user.
    I'm still confused!
    Over the last few days I have googled & found several posts on this issue but none with a simple and clear explanation and fix that works for me. Many posts just say ensure the user has read/write permission on the WordPress folders. The WordPress codex Extended itself seems to encourage manual upgrading! IIS Express via WebMatrix allows this to work automatically but I do not know it's settings.

    Help.......(this cannot be that hard! There is a post on digwp.com about editing ftp variables in wp-config which I haven't tried yet....)

  5. WPProHelp
    Member
    Posted 1 year ago #

    Hi richard,

    So why don't you add the FTP details in the wp-config? that should do the job for you as instead of using the user under which the web server is running, it uses the ftp user directly.

    Strictly speaking like that it is more secure as the web user should not have write access over other files and directories.

  6. richardpd
    Member
    Posted 1 year ago #

    Thanks WPProHelp
    The reason I do not want to edit wp-config is because I want to try & understand IIS localhost fully (including ftp) and insert the correct ftp credentials WordPress is asking for from the localhost IIS server!
    Nowhere can I find an answer to this but there have been many posts on the topic with other fixes proposed including editing the wp-config file. I find it so strange that none here on WP support forums can help me with this!?(still this unfortunately is not an isolated case-quite a few WordPress queries go unanswered in WP forums).Doesn't anyone know how to set up IIS localhost WIMP server with correct ftp credentials in IIS manager? Obviously not-the WordPress codex has a very basic page on WordPress in IIS but I have followed that without success.

    I posted a while back on wordpress.stackexchange(.com)& had a reply back from mauri which helped me autoupdate from IIS localhost to the latest WP version but by another means-not by inserting ftp credentials. See wordpress.stackexchange.com

    For me, this issue is still not fully resolved as my original question remains unanswered even though I have a fix by another means. Whether I will ever figure out the answer remains to be seen and I find it hard to believe with all the expert WordPress users around this problem has not been clearly answered before. Anyway, I still would like to know more about running WordPress in IIS localhost (WIMP server)and about IIS localhost in general and look forward to learning & using WordPress more.

  7. richardpd
    Member
    Posted 1 year ago #

    I still get this problem & still none can help me fix it.

    Why does WordPress ask for localhost FTP details to update to latest version in IIS localhost server & what are the ftp details for IIS I need to add (I have tried many combinations of username/passwords with no success). Why does WP do this when it does NOT do this when updating plugins? (plugins update automatically in IIS localhostserver!)?

    Please can someone at core wordpress.org development team sort this out!

  8. mikeill
    Member
    Posted 1 year ago #

    Nudge - any developments on this thread?

  9. CloudyBright
    Member
    Posted 12 months ago #

    I'm using XXAMP on IIs7.5 and auto-update will download the WP zip file and hangs on "unpacking". It simply hangs.

    Auto-update worked okay with Themes that had updates.
    I'm at a loss as to how to auto-update.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.