WordPress.org

Ready to get started?Download WordPress

Forums

IIS setup (21 posts)

  1. Definix
    Member
    Posted 5 months ago #

    I can browse the website in IIS or the servers web browser, but cannot use a browser on another computer on the network to browse it. (WordPress and phpMyAdmin) I'm sure I missed a step, but have looked back over the instructions a few times. I keep missing it and am feeling kinda stupid and frustrated right now.

    I have tried getting the path to a page from the browser http://localhost/wordpress/index.php and replacing "localhost" with the known IP address of the server to try to access it but still get HTTP Error 404 - File or directory not found.

    Help! lol

    My environment:
    Windows server 2003
    IIS 6
    phpMyAdmin 3.5.8
    Wordpress 3.8.1

    We host several websites. I have set them up and know how to point to the website in DNS and the properties of the website in IIS. WordPress installed in a sub folder in the default site. My default site is our company site.

    Thanks in advance for any help, and I will be glad to provide any more information needed to resolve my issue.

  2. jonradio
    Member
    Posted 5 months ago #

    No guarantees on this answer, but here is the logic I would use to explain what is going on.

    1. Assumption: the Site URL and WordPress URL settings both are http://localhost/wordpress
    2. You type http://1.2.3.4/wordpress from somewhere else on the network where localhost won't get you to your site
    3. WordPress gets your http request
    4. WordPress redirects it to localhost because that is how you set the Site URL and WordPress URL
    5. You end up at wherever localhost takes you from your network location
    6. There isn't a /wordpress/ folder at that localhost
    7. The browser correctly returns a 404

    If, and only if, I'm right, then changing your WordPress settings to use the numeric IP instead of localhost should solve your problem. The Settings I'm talking about are on the Admin panel on Settings-General.

    As I say, lots of "ifs" in this analysis.

  3. Definix
    Member
    Posted 5 months ago #

    OK. I tried changing http://localhost/wordpress to http://ServerIP/wordpress using the admin panel. I can no longer browse the site.

    I am currently trying to locate the file that holds the setting so I can manually change it back since I can no longer log into the site.

  4. Definix
    Member
    Posted 5 months ago #

    I was able to find the settings in the phpMyAdmin console under the wordpress database wp_options table. I changed it back to localhost and everything works now.

    Well... I am back to my original problem.

  5. jonradio
    Member
    Posted 5 months ago #

    http://codex.wordpress.org/Changing_The_Site_URL explains how to change back. Sorry!

  6. Definix
    Member
    Posted 5 months ago #

    I must have something somewhere conflicting with the address. I follow the instructions in the link you provided and I basically get the same results as I did when changing the localhost to the IP address.

    Add these lines to the wp-config.php

    update_option('siteurl','http://test.com');
    update_option('home','http://test.com');

    Load the page then remove the lines like the instructions say.

    I go to the phpMyadmin console and look at the wp_options table and it is showing siteurl http://test.com

  7. Definix
    Member
    Posted 5 months ago #

    I have decided at this point to delete phpMyAdmin and Wropress then try to install again.

  8. jonradio
    Member
    Posted 5 months ago #

    Sorry, but I was away from the office until now, so can give you a more lengthy answer.

    The solution to your problem lies in finding a common URL that works both on the server and from elsewhere on your network. And gets you to your web space, ignoring the WordPress piece of it for now. That URL will need to be the one you use for the WordPress URLs. That Codex page I gave you just tells you different ways to set those same values.

    Alternatively, you could give up accessing your site from the Server, and only access it from the Network, and then use the URL that works from the Network as the WordPress Settings' URLs.

    Does that make more sense?

  9. Definix
    Member
    Posted 5 months ago #

    To be honest, yes and no.

    I guess the part I am getting lost on is pointing correctly to the site. I have tried changing in the wp_options in phpMyAdmin and changing the wp-config.php directly making the path http://10.10.10.11/wordpress/ and trying http://test/com. Both times I get the 404 error from a web browser and if I right click the wordpress folder and select browse the page loads but without using any formatting. It is just listing the content down the left side of the page. I change it back to localhost and at least when accessed on the server it will be following the loaded theme layout.

    But now, if I tell it to go to the home page I get sent out to http://test.com. I don't know where to look to change this back so it doesn't send me out to the Internet.

    I didn't think about there actually being a http://test.com, which was very stupid on my part.

  10. jonradio
    Member
    Posted 5 months ago #

    To help me explain things, lets divide this into two problems. And solve each one individually.

    Stick a file into the root of your web site. From the server point of view, the URL will be, for now, http://localhost/test.txt

    Put the characters "abc" in the test.txt file.

    Now figure out a way to have one URL that works both from the server and from the network, and properly displays "abc" when you type it into your browsers on each workstation (server and network).

    I'll post Problem 2 in a minute.

  11. jonradio
    Member
    Posted 5 months ago #

    Once Problem 1 is solved, you can fix up WordPress. Delete the update_option and any define('WP_HOME','http://example.com'); and
    define('WP_SITEURL','http://example.com'); you might have in wp-config.php

    Then use phpMyAdmin and change the wp_options table, inserting the URL you figured out for Problem 1 for both siteurl and home.

  12. Definix
    Member
    Posted 5 months ago #

    OK. So far...

    I have changed the phpMyAdmin wp_options table back to http://localhost/wordpress/

    I then created the test.txt file with abc for the content.

    On the server I have http://localhost/wordpress/test.txt and showing abc in the browser.
    On my workstation I have http://10.10.10.11/wordpress/test.txt and am showing the 404 error.

  13. jonradio
    Member
    Posted 5 months ago #

    I'm not so good at IIS, but what you've done could be a problem if you were in an Apache environment, so just to be precise, could you move test.txt to the root? So, you would say http://localhost/test.txt from your server to get there. Picky, I know, but I've seen problems where WordPress is redirecting anything in its folder, not just WordPress "stuff".

    Assuming that http://10.10.10.11/test.txt still doesn't work from your workstation, now you have a problem that has nothing to do with WordPress, which is good because an IIS and/or Windows Server Network expert can fix it without knowing how to spell WordPress.

    I suspect that once you find out a valid URL to use from your network workstation to test.txt, you'll have a URL that will also work on the Server's workstation.

    Anyone you can ask in your own "shop"?

  14. Definix
    Member
    Posted 5 months ago #

    To further test it:

    I have changed the phpMyAdmin wp_options table back to http://10.10.10.11/wordpress/

    Doing this makes both the server and the workstation show a 404 error.

  15. Definix
    Member
    Posted 5 months ago #

    OH. I have multiple sites on this server. I can get to them by pointing say for instance CDCB to 10.10.10.11 in DNS and then edit the properties of the CDCB website to point CDCB and http://www.CDCB.com using port 80 to the CDCB site. Then I just enter CDCB in a browser from any workstation and it goes directly to the site. I dont know where to edit the settings for WordPress in IIS so that when I give DNS a value it will know where to direct the request.

  16. jonradio
    Member
    Posted 5 months ago #

    Which further confirms my suspicions that 10.10.10.11 is not correct, i.e. - wrong IP address, or not set up properly, to point at your IIS web server

  17. Definix
    Member
    Posted 5 months ago #

    The server is at address 10.10.10.11. All my DNS entries point to 10.10.10.11. They all work, except the wordpress and my phpMyAdmin console site.

  18. jonradio
    Member
    Posted 5 months ago #

    Assuming you want your WordPress web site to work from the Internet, not just your internal network, Site URL and WordPress URL must be set to the URLs that will work to get to your web space from the Internet. For example, if you own the domain name definix.com, and want this site to be on a subdomain, you might code "http://news.definix.com/wordpress".

    Of course, news.definix.com must also work on your internal network and on the server.

  19. Definix
    Member
    Posted 5 months ago #

    As stated earlier, I know how this is done, just not in WordPress. We are currently hosing 26 websites. We are looking at using a hosting solution like WordPress so we can allow our customers access to update their sites themselves.

    I can get to all 26 sites both internally and externally, but the WordPress site is not working and I am not sure where it is failing. I do not know where to go to tell IIS when it gets a request for test or http://www.test.com to point it to the WordPress directory. I could if it were a site I created, but I don't see where you set that for WordPress in IIS.

  20. jonradio
    Member
    Posted 5 months ago #

    I don't know enough about IIS configuration to explain things properly. What I do know is that WordPress redirects all requests it receives using the URLs coded as Site URL and WordPress URL. Which means they have to work everywhere you want your WordPress to work: on the server, on the internal network and from the Internet.

    So, I'll leave this thread to others to respond to.

  21. Definix
    Member
    Posted 5 months ago #

    Thank you for trying.

Reply

You must log in to post.

About this Topic