WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
[resolved] Ignores options for default operator and disabled fallback (3 posts)

  1. Biranit
    Member
    Posted 1 year ago #

    Hi,

    I have a clean install of Relevanssi on a new website that already has a fairly big number of documents.

    A couple of issues I am now facing:

    1) The options I set are to use "AND" as the default operator, and also disabled the OR fallback. I also elected not to use fuzzy search.

    Despite that, searching for John Doe (as an example) will bring up results for documents with only Doe. How to I force it to search for the entire string and not parts of it?

    2) Relevanssi was installed some 10 hours ago, and yet I still have the message at the top: "Relevanssi needs attention: Remember to build the index (you can do it at the settings page), otherwise searching won't work."

    The state of Index shows to be:

    Documents in the index: 2565
    Terms in the index: 1641191
    Highest post ID indexed: 46309

    (Checking our wp_posts table, 46309 is indeed the highest ID.)
    It's been that way for several hours now...

    Obviously issue #1 above is more crucial, but would like to understand what's going on with #2.

    Thank you for your assistance,

    Bira

    http://wordpress.org/extend/plugins/relevanssi/

  2. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    With #2, try clicking "Continue indexing". That might help. If nothing else works, add this to your functions.php, run it once and then remove:

    update_option('relevanssi_indexed', 'done');

    For #1, does that happen with every multi-word search you're trying? Setting the operator to AND should be enough.

  3. Biranit
    Member
    Posted 1 year ago #

    Hi Mikko,

    I found out what my error was - a wrong assumption on my part. For some reason, I thought AND means the two words are tied into a single phrase, so John Doe would only bring up results if "John Doe" exists, not John in one paragraph, and Doe in another... Call it brain fade on my part...

    Obviously searching for "John Doe" (with the quotation marks) does the trick - same as on Google. So all is well.

    As for the indexing - yes, I did do what you suggested, which is click on "continue indexing". Oh boy, it does not seem to end. It currently stands on:

    Documents in the index: 5931
    Terms in the index: 3221238
    Highest post ID indexed: 49513

    When it will ever end, I've no idea... but I guess I just need to be patient...

    Thanks for a great plugin - and for your response. Very much appreciated.

    Best,

    Biranit

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags