WordPress.org

Ready to get started?Download WordPress

Forums

Iframes are deleted (3 posts)

  1. kjetilgf
    Member
    Posted 6 years ago #

    When I insert an iframe code in a post or page the code is deleted automatically - if I open the post/page in Visual view. Is there a piece of code or plugin I can use to avoid that?
    To insert the code, of course I have to go to html view. If I just save the post/page there, everything works fine. Its if I accidentally open such post/page in Visual view that WP deletes it.
    The only solution I've found is to make copies of the code in all such posts/pages in text docs and store them locally. If I accidentally open the page/post in visual view, I can paste in the backup.
    But isn't there any way to avoid this deletion?
    Thanks,
    Kjetil

    (I just posted the same question by mistake in the Installation forum - it's also relevant in that thread, so I left it. Delete it if I've done wrong, please.)

  2. moshu
    Member
    Posted 6 years ago #

    But isn't there any way to avoid this deletion?

    Yes, turn off the wysiwyg animal for good. It is for code illiterates. If you know code you don't need it. It's that simple.

  3. kjetilgf
    Member
    Posted 6 years ago #

    OK - thanks Moshu
    The thing is, its not only me editing this site - and I find it weird that an otherwise brilliant system like WP still has this "feature".
    Anyway, making a code backup for those posts is quite easy.

Topic Closed

This topic has been closed to new replies.

About this Topic