WordPress.org

Ready to get started?Download WordPress

Forums

iframe not showing height as set in embed code (6 posts)

  1. rymandev
    Member
    Posted 5 years ago #

    On my blog's page "Community Events & Calendar" I placed an iframes code to embed a web page of the Zvents site for my area.

    The code I placed in the "Page" from the WP Dashboard was:

    <iframe src="http://www.zvents.com" width="900"

    height="900" frameborder="0" allowtransparency="true" scrolling="yes"

    title="embed"></iframe>

    When finished, the page in either Firefox or IE shows the embedded frame with a very small height, barely showing the embedded page at all.

    On another page on my blog "Jobs Board" I embedded a different web page using the exact same code and the finished page shows it with a full height.

    I tried making changes to the code, I tried adding text below the embedded frame to make the body's frame larger, I even deleted the page completely and then created it again from scratch. I'm using the same page attributes template for both pages, and can find no differences between the two in how I set them up. The only difference is the finished look of the embedded page.

    Help! This frame is very looking pretty bad!

    Thanks for your help...

  2. rymandev
    Member
    Posted 5 years ago #

    Forgot to mention, the same thing is happening on this page. Can't figure out why the height setting shows correctly on only 1 of 3 pages on my blog when all the settings are the same and the code is the same except for the site it pulls from.

  3. figaro
    Member
    Posted 5 years ago #

    When I look at the html in firebug, I don't see the height being defined on the first one...I do see it on the second one. Look closely and make sure you don't have a formatting error on the height attribute in that first example.

  4. figaro
    Member
    Posted 5 years ago #

    Take all the <p> and </p> tags off that are in the iframe and see if that helps.

  5. rymandev
    Member
    Posted 5 years ago #

    Found the error. Funny what a missing a little quotation mark will do...

    Thanks, figaro!

  6. figaro
    Member
    Posted 5 years ago #

    You're welcome...those little quotation marks have sucked up hours of my troubleshooting time in the past...and I'm sure they will continue to do it the future ;-)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags