WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Robots.txt Manager
If you do NOT have Subdomains or Sub-directories, DO NOT INSTALL!!! (2 posts)

1 star
  1. jonathandpeck
    Member
    Posted 1 year ago #

    Please do as the developer suggests and do a manual FTP delete. Please do this first.

    "You will need to manually delete the plugin via ftp. It can be found within /wp-content/plugins/ms-robotstxt-manager."

    http://wordpress.org/support/topic/plugin-multisite-robotstxt-manager-problem-with-plugin-activation?replies

    I found this after deactivating all my plugins, setting up a multisite by turning on networking. Tools> Networking, I had to change the .htcaccess file and the wp-config.php files. This all took about 30 minutes. It took 5 minutes to undo it. I had commented out what they wanted me to replace and kept a back up copy of the files just in case.

    It took me 5 minutes to delete the plugin folder, edit the 2 files back to their original state, log out and log back in, reactivate my plugins, and fixed. Plugin is now gone.

  2. tribalNerd
    Member
    Plugin Author

    Posted 1 year ago #

    Hello again jonathandpeck,

    Correct, if your WordPress install is not Multisite Network enabled, do not install the "Multisite" Robots.txt Manager plugin.

    As stated on the plugins homepage, download page, help documents and readme file "This Plugin Was Created For Multisite Networks > Network Activations Only!"

    The error you experienced was due to a function within the uninstall.php file that is Multisite only. Because your setup was not network enabled, Worpress would stop the removal process once it hit that function.

    This issue has been corrected.

    With removing the plugin, all you needed to do was delete it via ftp, you didn't need to network enable your setup, then delete it.

    ~Chris

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.