WordPress.org

Ready to get started?Download WordPress

Forums

Social Connect
If you are having problems with connecting to Facebook... (16 posts)

  1. L D
    Member
    Posted 3 years ago #

    If you are getting warnings for using file_get_contents, then it means your host has disabled fopen use. Don't go around by enabling it with a php.ini. Instead, do the following:

    Find and open social-connect/facebook/callback.php.

    Place the following code before $client_id = get_option... and after require_once(dirname(dirname(__FILE__)) . '/utils.php' );...

    function curl_get_contents ($url) {
    $curl = curl_init();
    curl_setopt($curl, CURLOPT_RETURNTRANSFER, 1);
    curl_setopt($curl, CURLOPT_URL, $url);
    $html = curl_exec($curl);
    curl_close($curl);
    return $html;
    }

    Find parse_str(file_get_contents and replace with
    parse_str(curl_get_contents

  2. vbk100
    Member
    Posted 3 years ago #

    As I posted here . I have a different problem. When a user login with Facebook, he redirect back to login page. Not getting any error messages,but redirecting to the login page again and again

    I hope you can help me with this. Can you please tell me how to solve that issue

    My WordPress version is 3.2.1 and the plugin version is 0.7

  3. L D
    Member
    Posted 3 years ago #

    You're talking about the quick popup that closes automatically and then redirects you to the login page. That's the fix above.

  4. thenbrent
    Member
    Plugin Author

    Posted 2 years ago #

    L D, thanks for sharing. I've modified the core to use your curl_get_contents function.

    vbk100 & L D could you both please download the latest version from here: https://github.com/thenbrent/social-connect/zipball/master

    Test it out and let me know if it solves the errors for you.

  5. vbk100
    Member
    Posted 2 years ago #

    @Thenbrent

    I have uploaded the new plugin. But it is still redirecting to login page when trying to login with facebook

    Can you please help me if I provide you the login details and URL of my site?
    ffav dot in/wp-login.php is the URL

  6. thenbrent
    Member
    Plugin Author

    Posted 2 years ago #

    vbk100 firstly double check your Facebook application settings. Best to delete the application and then create a new one adding the new keys.

    Then, make sure you have run the Rewrite Diagnostics test shown in the Settings > Social Connect. If you're still having the wp-login.php problem, disable all other plugins (especially those related to logins etc.) and try again.

  7. vbk100
    Member
    Posted 2 years ago #

    Thenbrent ,

    I have deleted the current plugin version and installed the new version. Later deleted the facebook app and created a fresh one. All the plugins were de-activated except the two . That is before I submit my last message.

    Now on your word, I have created Facebook app again and de-activated all the plugins including must-use plugins (Installation type is of Multisite.But checking the plugin on each site separately ). Tried the same procedure for three times without no success (Rewrite Diagnostics are also fine)

    Can you please allow me to send login details, so that you can check them on your end

  8. thenbrent
    Member
    Plugin Author

    Posted 2 years ago #

    I've reproduced the problem and am working on a fix. Hopefully will have one within a day or two.

  9. markusdrake
    Member
    Posted 2 years ago #

    Bah, somebody beat me to the idea of the curl function. I'm also trying to help vbk (on the other site). Looks like he's having an issue with the function opening the file still.

  10. thenbrent
    Member
    Plugin Author

    Posted 2 years ago #

    haha thanks for helping out again Markus! I've adding the curl function to both offending places. file_get_contents() is still used in the OpenID class, but the Facebook sections were the culprits here.

  11. markusdrake
    Member
    Posted 2 years ago #

    Not a problem, sorry for dropping off the planet for a while - super busy and studying for certifications. Looking forward to getting involved in a few more projects here and helping out a little more on the forums. I told vbk I could look at it sometime this weekend if you need any assistance.

  12. abali
    Member
    Posted 2 years ago #

    Hi guys,

    I'm a bit new to the world of wordpress so perhaps I'm doing something simple wrong, but i think i am experiencing the problem being described in this thread.

    When I go to my website (http://bufferbox.com), and connect using Facebook, a pop-up appears which asks me to grant permissions to FB. When I press allow, the pop-up window just goes white and nothing happens on my homepage. When I check my FB account which i used to connect, the app shows up but when I check my website's user database, nothing is registered. (aside: I have a similar behavior with twitter connect login)

    I have tried implementing the "function curl_get_contents ($url)" exactly as specified in this thread as well as remaking the FB app to get new keys. In wordpress I enter the "API Key" as a 16 digit numeric code and the "Secret Key" as a 33 digit alpha-numeric code.

    Am I setting up something incorrectly or is this a known bug that I am experiencing? Thanks!

  13. vbk100
    Member
    Posted 2 years ago #

  14. L D
    Member
    Posted 2 years ago #

    @brent & abali

    Sorry, I forgot to mention one more change I made...

    /social-connect/social-connect.php

    change...

    $fb_json = json_decode( file_get_contents("https://graph.facebook.com/me?access_token=" . $_REQUEST[ 'social_connect_access_token' ]) );

    to

    $fb_json = json_decode( curl_get_contents("https://graph.facebook.com/me?access_token=" . $_REQUEST[ 'social_connect_access_token' ]) );

    and in your case, Brent, it would be sc_curl_get_contents. I think that's all I changed... if not, well, you'll know when it breaks! ;)

  15. L D
    Member
    Posted 2 years ago #

    @Brent

    Oh, since you're going to roll out a new update, could you move the buttons to above the comment form? I think it's a more logical place to put it. If I'm commenting, I would like to login and then type out my comments rather than to type out my comments and discover that I could've logged in using some other service.

    Open ui.php in the social-connect plugin folder...

    Find add_action( 'comment_form and replace with add_action( 'comment_form_top

    I think an option for both locations would probably be best though since not everyone's theme will support 'comment_form_top'.

    Ref: http://wordpress.org/support/topic/plugin-social-connect-how-to-put-social-connect-tool-up-above-submit?replies=4

  16. thenbrent
    Member
    Plugin Author

    Posted 2 years ago #

    HI L D, yep I'll change that now. Thanks for pointing it out. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic