WordPress.org

Ready to get started?Download WordPress

Forums

if htaccess file were writable - BUT IT IS!!! (17 posts)

  1. paulbuijs
    Member
    Posted 5 years ago #

    htaccess file shows as not writable when trying to update permalinks - even though I've given it 777 file permissions through both my ftp client and the host????

    When I try to update the permalinks of my WP site http://kokorocombatives.com to /%post_id%/%postname%/ I get the "You should update your .htaccess now." message in the permalinks settings. I copied the code below for manual entry into the .htaccess file and the permalinks changed to the desired structure but I am baffled why the admin section still shows the htaccess file as unwritable when I have given it full access.

    This would seem like something silly to worry about but in my test site http://titaniumeffect.com/kokorocombatives.com when i change the permalinks I do not get that message. I am on Godaddy on the test site and on 1and1 for the client's production site. Whatever the difference is, I think it is causing my global translator plugin to fail on the 1and1 site when not using the default ugly permalinks. The plugin works fine on the test site. Any tips or quick observations? I have been scratching my head on this one for days!!!! I have made sure both sites have the same plugins and tried deactivating and even deleting plugins to kill any conflicts.

    Thanks all, for helping a fellow WP enthusiast. Please forgive me if I've broken some forum etiquette as this is my first post. I've done my best to do my research first. Let me know if you need additional info.

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    What server OS? Windows or Linux?

  3. The5sisters
    Member
    Posted 5 years ago #

    It's not the .htaccess file (there are 3 by the way) that needs to be writable but the wp-config.php file [temporarily at least].Besides,you can copy and paste into the main .htaccess file using c-panel or the GoDaddy equivalent.Don't use FTP for this It is possible but complicated because FTP relies on htaccess to delete,upload,download and paste or overwrite files.
    If you don't like the looks of the permalinks install the latest 'PrettyLinks" plug-in.

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    It's not the .htaccess file (there are 3 by the way) that needs to be writable but the wp-config.php file [temporarily at least]

    Pardon? The rewrite rules are written to the WP root .htaccess file. wp-config.php has nothing to do with it.

    @paulbuijs:
    Have a look at:

    http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

    Perhaps there's something in there that might help.

  5. ClaytonJames
    Member
    Posted 5 years ago #

    ???

    It's not the .htaccess file (there are 3 by the way) that needs to be writable

    It may indeed not be the .htaccess file, but there is only one, unless others have been specifically created by the user.

    It's not the .htaccess file (there are 3 by the way) that needs to be writable but the wp-config.php file

    Why would wp-config.php ever need to be writeable?

    Don't use FTP for this It is possible but complicated because FTP relies on htaccess to delete,upload,download and paste or overwrite files.

    Absolutely not the case. FTP couldn't care less about your .htaccess file. It has nothing to do using with an ftp client.

    As you can see, the OP solved the problem with a manual edit. The only question that remains is why the specific/unusual permissions behavior on the (GoDaddy?) host.

    "I copied the code below for manual entry into the .htaccess file and the permalinks changed to the desired structure but I am baffled why the admin section still shows the htaccess file as unwritable when I have given it full access."

  6. ClaytonJames
    Member
    Posted 5 years ago #

    Darn it, esmi, you're a full step ahead of me AGAIN! All this typing with one hand sucks... (broken finger). Ahh, well time for my, umm... "pain medication" ("..two ice cubes and a splash of soda with that please..")

    :P

  7. esmi
    Forum Moderator
    Posted 5 years ago #

    Ouch! I hope the hand heals soon but enjoy the pain medication whilst you can.

  8. ClaytonJames
    Member
    Posted 5 years ago #

    Thanks!

    :-)

  9. figaro
    Member
    Posted 5 years ago #

    Clayton...have another WR on me ;-)

  10. ClaytonJames
    Member
    Posted 5 years ago #

    You know, I wrote that down last time you mentioned it, and I am so going to try it. I'm such a creature of habit that I just actually need to write it down on the grocery list (hee.. heee.. grocery list. Now, that's funny) so I remember to look for it.

    :P

  11. figaro
    Member
    Posted 5 years ago #

    Let me know what you think...it's the best I've found. I actually got around to taking a tour of their facility a few weeks ago (live about 30 miles from there) and it's pretty impressive.

  12. ClaytonJames
    Member
    Posted 5 years ago #

    I will definitely let you know. I toured the JD distillery back in '85. What a time. Lynchburg TN was like stepping back in time about 100 years. I understand it hasn't changed much. Very, very cool. Odd thing was, Lynchburg itself (Moore?) county was a dry county. Go figure. Water, water, everywhere and not a drop to drink!

  13. paulbuijs
    Member
    Posted 5 years ago #

    Hey guys, thanks for looking at this issue. The host where I'm having this issue is on 1and1. Everything works fine on GoDaddy. The reason why I'm trying to figure this out is because I think it is related to why my Global Translator plugin and Ashford theme hero image functionality do not work. See them in action on the GoDaddy site. On the problem site the Global Translator plugin only works when I have the default ugly permalinks. It works fine with custom permalinks on GoDaddy. I read somewhere that after changing permalinks structure I need to save the settings again in Global Translator. I've done that several times - unsuccessfully.

  14. esmi
    Forum Moderator
    Posted 5 years ago #

    Are you on a Windows or Linux server? I've run WP on a 1&1 Linux server without any problems. But Windows servers can sometimes have problems with permalinks/.htaccess.

  15. paulbuijs
    Member
    Posted 5 years ago #

    esmi,

    I just called 1and1 and verified that it's a linux account. I just can't get Global translator to work with any permalink structure other than the default on this site. I have it working on several other sites. Also that no matter what settings I change, the admin section keeps telling me the .htaccess file isn't writable when it is. Am I wasting my time with this .htaccess problem? I think the two issues are related somehow.

  16. esmi
    Forum Moderator
    Posted 5 years ago #

    I just can't get Global translator to work with any permalink structure other than the default on this site.

    That could be due to a problem within this particular plugin rather than any fault in your WP setup. Have you checked to see whether it's listed as compatible with WP 2.8? Not all plugins are.

  17. paulbuijs
    Member
    Posted 5 years ago #

    esmi,

    My test site http://titaniumeffect.com/kokorocombatives.com is running 2.8.4 with permalink structure
    /%post_id%/%postname%/
    and the same version of Global Translator and it runs fine :(
    I either screwed up something in the database transfer or there is something different with 1and1 (besides needing to be told to run PHP 5 which I've already addressed in the .htaccess). I went a did a find and replace of all reference of the old url for the new in the databse through both the MySQL control area and through a plugin. I've also tried deactivating the Redirection plugin several times thinking there may be a conflict there but no such luck. I also have that plugin working fine alongside Global Translator on the test site.

Topic Closed

This topic has been closed to new replies.

About this Topic